commit c814dfa78c8c50d0a173a739d730858364d2318c
parent 63d55a3976b1decdfbfe02500ce6831d57c87f59
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Wed, 1 Jan 2020 02:48:48 +0300
Add pymbtiles
Diffstat:
3 files changed, 33 insertions(+), 0 deletions(-)
diff --git a/default.nix b/default.nix
@@ -78,6 +78,9 @@ in rec {
openorienteering-mapper = libsForQt5.callPackage ./pkgs/openorienteering-mapper {
inherit (sources) mapper;
};
+ pymbtiles = python3Packages.callPackage ./pkgs/pymbtiles {
+ inherit (sources) pymbtiles;
+ };
qmapshack-maps = callPackage ./pkgs/qmapshack-maps { };
redict = libsForQt5.callPackage ./pkgs/redict {
inherit (sources) redict;
diff --git a/nix/sources.json b/nix/sources.json
@@ -227,6 +227,18 @@
"url": "https://github.com/mapbox/mbutil/archive/2fc4161f9be890a65d07f5e7b2ed0c8a0a123ed6.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
+ "pymbtiles": {
+ "branch": "master",
+ "description": "Python utilities for Mapbox mbtiles files",
+ "homepage": "https://github.com/consbio/pymbtiles",
+ "owner": "consbio",
+ "repo": "pymbtiles",
+ "rev": "02fbee6e935b9990e98874925b091e07ff89bdb0",
+ "sha256": "1gjvl0ywwl74ilkmq2m94my1m5v2m1qlfzs1kvkgxd32sl5yg9dv",
+ "type": "tarball",
+ "url": "https://github.com/consbio/pymbtiles/archive/02fbee6e935b9990e98874925b091e07ff89bdb0.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
"redict": {
"branch": "master",
"description": "A dictionary for Linux, based on C++/Qt development.",
diff --git a/pkgs/pymbtiles/default.nix b/pkgs/pymbtiles/default.nix
@@ -0,0 +1,18 @@
+{ lib, buildPythonPackage, pytest, pymbtiles }:
+
+buildPythonPackage rec {
+ pname = "pymbtiles";
+ version = lib.substring 0 7 src.rev;
+ src = pymbtiles;
+
+ checkInputs = [ pytest ];
+ checkPhase = "pytest";
+
+ meta = with lib; {
+ description = pymbtiles.description;
+ homepage = pymbtiles.homepage;
+ license = licenses.isc;
+ maintainers = with maintainers; [ sikmir ];
+ platforms = platforms.unix;
+ };
+}