commit 1d6fad292b39c6ba8379ff868d6eac0ef7549849
parent 3d84bf73212ba4b0a829acf4c9b39743dcd48390
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Wed, 22 Sep 2021 23:44:35 +0300
Move visualgps to gnss
Diffstat:
3 files changed, 44 insertions(+), 44 deletions(-)
diff --git a/pkgs/applications/visualgps/default.nix b/pkgs/applications/visualgps/default.nix
@@ -1,43 +0,0 @@
-{ lib
-, stdenv
-, mkDerivation
-, fetchFromGitHub
-, qmake
-, qtserialport
-}:
-
-mkDerivation rec {
- pname = "visualgps-unstable";
- version = "2020-03-29";
-
- src = fetchFromGitHub {
- owner = "VisualGPS";
- repo = "VisualGPSqt";
- rev = "f2e213208a48e1f7d7294bc832a848de4efb4fd4";
- sha256 = "sha256-1x9V75Y2QgMw3oTERHiFopFxFyWRJhGKaDK/raPqxjg=";
- fetchSubmodules = true;
- };
-
- nativeBuildInputs = [ qmake ];
-
- buildInputs = [ qtserialport ];
-
- qmakeFlags = [ "Software/VisualGPSqt/Source/VisualGPSqt.pro" ];
-
- postInstall =
- if stdenv.isDarwin then ''
- mkdir -p $out/Applications
- mv *.app $out/Applications
- wrapQtApp $out/Applications/VisualGPSqt.app/Contents/MacOS/VisualGPSqt
- '' else ''
- install -Dm755 VisualGPSqt -t $out/bin
- '';
-
- meta = with lib; {
- description = "A QT application (GUI) that makes use of the VisualGPS/NMEAParser project";
- inherit (src.meta) homepage;
- license = licenses.mit;
- maintainers = [ maintainers.sikmir ];
- platforms = platforms.unix;
- };
-}
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -19,7 +19,6 @@ lib.makeScope newScope (
openorienteering-mapper-bin = callPackage ./applications/gis/openorienteering-mapper/bin.nix { };
qutebrowser-bin = callPackage ./applications/networking/qutebrowser/bin.nix { };
synwrite-bin = callPackage ./applications/synwrite/bin.nix { };
- visualgps = libsForQt5.callPackage ./applications/visualgps { };
wireguard-statusbar-bin = callPackage ./applications/wireguard-statusbar { };
### BUILD SUPPORT
@@ -210,6 +209,7 @@ lib.makeScope newScope (
### GNSS
rtklib = callPackage ./gnss/rtklib { };
+ visualgps = libsForQt5.callPackage ./gnss/visualgps { };
### GPX
diff --git a/pkgs/gnss/visualgp/default.nix b/pkgs/gnss/visualgp/default.nix
@@ -0,0 +1,43 @@
+{ lib
+, stdenv
+, mkDerivation
+, fetchFromGitHub
+, qmake
+, qtserialport
+}:
+
+mkDerivation rec {
+ pname = "visualgps-unstable";
+ version = "2020-03-29";
+
+ src = fetchFromGitHub {
+ owner = "VisualGPS";
+ repo = "VisualGPSqt";
+ rev = "f2e213208a48e1f7d7294bc832a848de4efb4fd4";
+ sha256 = "sha256-1x9V75Y2QgMw3oTERHiFopFxFyWRJhGKaDK/raPqxjg=";
+ fetchSubmodules = true;
+ };
+
+ nativeBuildInputs = [ qmake ];
+
+ buildInputs = [ qtserialport ];
+
+ qmakeFlags = [ "Software/VisualGPSqt/Source/VisualGPSqt.pro" ];
+
+ postInstall =
+ if stdenv.isDarwin then ''
+ mkdir -p $out/Applications
+ mv *.app $out/Applications
+ wrapQtApp $out/Applications/VisualGPSqt.app/Contents/MacOS/VisualGPSqt
+ '' else ''
+ install -Dm755 VisualGPSqt -t $out/bin
+ '';
+
+ meta = with lib; {
+ description = "A QT application (GUI) that makes use of the VisualGPS/NMEAParser project";
+ homepage = "http://visualgps.net/";
+ license = licenses.mit;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.unix;
+ };
+}