commit 3d84bf73212ba4b0a829acf4c9b39743dcd48390
parent 1c7061c3577aa9a16427c5f4a2a3955b6ff22ba7
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Wed, 22 Sep 2021 23:34:53 +0300
Add rtklib
Diffstat:
2 files changed, 43 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -207,6 +207,10 @@ lib.makeScope newScope (
sasplanet-bin = callPackage ./gis/sasplanet/bin.nix { };
tdh = callPackage ./gis/tdh { };
+ ### GNSS
+
+ rtklib = callPackage ./gnss/rtklib { };
+
### GPX
cmpgpx = callPackage ./gpx/cmpgpx { };
diff --git a/pkgs/gnss/rtklib/default.nix b/pkgs/gnss/rtklib/default.nix
@@ -0,0 +1,39 @@
+{ lib, stdenv, fetchFromGitHub, gfortran }:
+
+stdenv.mkDerivation rec {
+ pname = "rtklib";
+ version = "2.4.3-b34";
+
+ src = fetchFromGitHub {
+ owner = "tomojitakasu";
+ repo = pname;
+ rev = "v${version}";
+ hash = "sha256-d9hpvmIdSZ3BervVZVvfRTc+q7wUWoWLF81TAsMGe68=";
+ };
+
+ nativeBuildInputs = [ gfortran ];
+
+ buildPhase = ''
+ make -C lib/iers/gcc
+ make -C app/consapp
+ '';
+
+ installPhase = ''
+ install -Dm755 app/consapp/pos2kml/gcc/pos2kml -t $out/bin
+ install -Dm755 app/consapp/str2str/gcc/str2str -t $out/bin
+ install -Dm755 app/consapp/rnx2rtkp/gcc/rnx2rtkp -t $out/bin
+ install -Dm755 app/consapp/rtkrcv/gcc/rtkrcv -t $out/bin
+ install -Dm755 app/consapp/convbin/gcc/convbin -t $out/bin
+
+ install -Dm644 app/consapp/rnx2rtkp/gcc/*.conf -t $out/share/rtklib/rnx2rtkp
+ '';
+
+ meta = with lib; {
+ description = "An Open Source Program Package for GNSS Positioning";
+ homepage = "http://www.rtklib.com/";
+ license = licenses.bsd2;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.linux;
+ skip.ci = stdenv.isDarwin;
+ };
+}