commit 1c3854dabb1b6e588aa4c0a46cee00642caf3562
parent 1e9303ea55f3c9f5b8dba3ff84072888ef3e9653
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Wed, 1 Jan 2020 03:19:46 +0300
Add tpkutils
Diffstat:
3 files changed, 37 insertions(+), 0 deletions(-)
diff --git a/default.nix b/default.nix
@@ -101,6 +101,11 @@ in rec {
supload = callPackage ./pkgs/supload {
inherit (sources) supload;
};
+ tpkutils = python3Packages.callPackage ./pkgs/tpkutils {
+ inherit mercantile;
+ inherit pymbtiles;
+ inherit (sources) tpkutils;
+ };
ueberzug = python3Packages.callPackage ./pkgs/ueberzug {
inherit (sources) ueberzug;
};
diff --git a/nix/sources.json b/nix/sources.json
@@ -287,6 +287,18 @@
"url": "https://github.com/selectel/supload/archive/70690682867713c68d7c6daa833a1013e79df407.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
+ "tpkutils": {
+ "branch": "master",
+ "description": "ArcGIS Tile Package Utilities",
+ "homepage": "https://github.com/consbio/tpkutils",
+ "owner": "consbio",
+ "repo": "tpkutils",
+ "rev": "5aec5e5a996b16575812d90586a5cd1e865437bf",
+ "sha256": "06izbgq912qlbhwgas0ycnsx2hniya5bdb24x2bd3i19wlhrps36",
+ "type": "tarball",
+ "url": "https://github.com/consbio/tpkutils/archive/5aec5e5a996b16575812d90586a5cd1e865437bf.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
"ueberzug": {
"branch": "master",
"description": "ueberzug is an alternative for w3mimgdisplay",
diff --git a/pkgs/tpkutils/default.nix b/pkgs/tpkutils/default.nix
@@ -0,0 +1,20 @@
+{ lib, buildPythonApplication, mercantile, pymbtiles, pytest, setuptools, six, tpkutils }:
+
+buildPythonApplication rec {
+ pname = "tpkutils";
+ version = lib.substring 0 7 src.rev;
+ src = tpkutils;
+
+ propagatedBuildInputs = [ mercantile pymbtiles setuptools six ];
+
+ checkInputs = [ pytest ];
+ checkPhase = "pytest";
+
+ meta = with lib; {
+ description = tpkutils.description;
+ homepage = tpkutils.homepage;
+ license = licenses.isc;
+ maintainers = with maintainers; [ sikmir ];
+ platforms = platforms.unix;
+ };
+}