commit 0d350b2ba2de5d548efa7c9fe52e8e15709b1f18
parent d326ac86af7fbf613f2d2396ffbecad44253a463
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Mon, 21 Aug 2023 21:52:49 +0400
Add sequel-ace
Diffstat:
2 files changed, 33 insertions(+), 0 deletions(-)
diff --git a/pkgs/darwin/sequel-ace/default.nix b/pkgs/darwin/sequel-ace/default.nix
@@ -0,0 +1,32 @@
+{ lib, stdenvNoCC, fetchfromgh, unzip }:
+
+stdenvNoCC.mkDerivation (finalAttrs: {
+ pname = "sequel-ace-bin";
+ version = "4.0.7";
+
+ src = fetchfromgh {
+ owner = "Sequel-Ace";
+ repo = "Sequel-Ace";
+ name = "Sequel-Ace-${finalAttrs.version}.zip";
+ hash = "sha256-yTaj2HvhGwGKB/YqaBkYWD3B9gpn/KS+joTxo0ytBiM=";
+ version = "production/${finalAttrs.version}-20050";
+ };
+
+ sourceRoot = ".";
+
+ nativeBuildInputs = [ unzip ];
+
+ installPhase = ''
+ mkdir -p $out/Applications
+ cp -r *.app $out/Applications
+ '';
+
+ meta = with lib; {
+ description = "MySQL/MariaDB database management for macOS";
+ homepage = "https://sequel-ace.com/";
+ license = licenses.free;
+ maintainers = [ maintainers.sikmir ];
+ platforms = [ "x86_64-darwin" ];
+ skip.ci = true;
+ };
+})
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -40,6 +40,7 @@ lib.makeScope newScope (
podman-desktop-bin = callPackage ./darwin/podman-desktop/bin.nix { };
qtcreator-bin = callPackage ./darwin/qtcreator/bin.nix { };
qutebrowser-bin = callPackage ./darwin/qutebrowser/bin.nix { };
+ sequel-ace-bin = callPackage ./darwin/sequel-ace { };
sloth-bin = callPackage ./darwin/sloth { };
### DATA