commit d326ac86af7fbf613f2d2396ffbecad44253a463
parent 78ae2217129026f7396bd9af85d227c7849f6c61
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sat, 19 Aug 2023 15:51:43 +0400
Up
Diffstat:
2 files changed, 20 insertions(+), 1 deletion(-)
diff --git a/pkgs/geospatial/mapsoft/2.nix b/pkgs/geospatial/mapsoft/2.nix
@@ -3,6 +3,9 @@
, fetchFromGitHub
, fetchpatch
, substituteAll
+, copyDesktopItems
+, desktopToDarwinBundle
+, makeDesktopItem
, db
, fig2dev
, giflib
@@ -85,14 +88,26 @@ stdenv.mkDerivation (finalAttrs: {
substituteInPlace vmap_data/scripts/vmaps.sh --replace "/usr" "$out"
'';
+ desktopItems = [
+ (makeDesktopItem {
+ name = "ms2view";
+ exec = "ms2view";
+ comment = "Viewer for geodata and raster maps";
+ desktopName = "ms2view";
+ genericName = "Mapsoft2 viewer";
+ categories = [ "Geography" "Geoscience" "Science" ];
+ })
+ ];
+
nativeBuildInputs = [
+ copyDesktopItems
fig2dev
imagemagick
perlPackages.perl
pkg-config
unzip
wrapGAppsHook
- ];
+ ] ++ lib.optional stdenv.isDarwin desktopToDarwinBundle;
buildInputs = [
db
diff --git a/pkgs/misc/opcua-stack/default.nix b/pkgs/misc/opcua-stack/default.nix
@@ -13,6 +13,10 @@ stdenv.mkDerivation rec {
sourceRoot = "${src.name}/src";
+ postPatch = ''
+ substituteInPlace CMakeLists.txt --replace "/usr" "$out"
+ '';
+
nativeBuildInputs = [ cmake ];
buildInputs = [ boost openssl ];