commit 0432ecc5b1ad2ece4734a074bf0b2c8ea191370b
parent 638c8ccda1ea47ca7f56dceba295ca401fdfb2bc
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Fri, 3 Sep 2021 10:14:06 +0300
Add rio-mbtiles
Diffstat:
2 files changed, 36 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -115,6 +115,7 @@ lib.makeScope newScope (
mbtiles2osmand = callPackage ./tools/geo/mbtiles2osmand { };
py-staticmaps = callPackage ./tools/geo/py-staticmaps { };
render_geojson = callPackage ./tools/geo/render_geojson { };
+ rio-mbtiles = callPackage ./tools/geo/rio-mbtiles { };
supermercado = callPackage ./tools/geo/supermercado { };
tile-stitch = callPackage ./tools/geo/tile-stitch { };
tilesets-cli = callPackage ./tools/geo/tilesets-cli { };
diff --git a/pkgs/tools/geo/rio-mbtiles/default.nix b/pkgs/tools/geo/rio-mbtiles/default.nix
@@ -0,0 +1,35 @@
+{ lib, fetchFromGitHub, python3Packages, supermercado }:
+
+python3Packages.buildPythonApplication rec {
+ pname = "rio-mbtiles";
+ version = "1.6.0";
+
+ src = fetchFromGitHub {
+ owner = "mapbox";
+ repo = pname;
+ rev = version;
+ hash = "sha256-Kje443Qqs8+Jcv3PnTrMncaoaGDdjrzTcd42NYIenuU=";
+ };
+
+ propagatedBuildInputs = with python3Packages; [
+ click
+ cligj
+ mercantile
+ numpy
+ supermercado
+ tqdm
+ shapely
+ ];
+
+ checkInputs = with python3Packages; [ pytestCheckHook ];
+
+ disabledTests = [ "test_cutline_progress_bar" ];
+
+ meta = with lib; {
+ description = "A plugin command for the Rasterio CLI that exports a raster dataset to an MBTiles 1.1 SQLite file";
+ inherit (src.meta) homepage;
+ license = licenses.mit;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.unix;
+ };
+}