commit 638c8ccda1ea47ca7f56dceba295ca401fdfb2bc
parent ba26865b92c33bd3879267a2200b998baac97e4b
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Thu, 2 Sep 2021 13:57:59 +0300
Add gps-whatsnew
Diffstat:
2 files changed, 35 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -207,6 +207,7 @@ lib.makeScope newScope (
cmpgpx = callPackage ./gpx/cmpgpx { };
geojson2dm = callPackage ./gpx/geojson2dm { };
+ gps-whatsnew = callPackage ./gpx/gps-whatsnew { };
gpx-animator = callPackage ./gpx/gpx-animator { };
gpx-cmd-tools = callPackage ./gpx/gpx-cmd-tools { };
gpx-interpolate = callPackage ./gpx/gpx-interpolate { };
diff --git a/pkgs/gpx/gps-whatsnew/default.nix b/pkgs/gpx/gps-whatsnew/default.nix
@@ -0,0 +1,34 @@
+{ lib, stdenv, fetchFromGitHub, boost, qt5 }:
+
+stdenv.mkDerivation rec {
+ pname = "gps-whatsnew";
+ version = "2017-01-23";
+
+ src = fetchFromGitHub {
+ owner = "centurn";
+ repo = pname;
+ rev = "b856f0b7472ed6287920a41568d951e0a0330387";
+ hash = "sha256-lZSjFdaQizXYi0OTChOKrSwllgzOCy6gTbBohcegJxk=";
+ };
+
+ postPatch = ''
+ sed -i '1 i #include <iostream>' gps_analyze.cpp
+ '';
+
+ nativeBuildInputs = [ qt5.qmake ];
+ buildInputs = [ boost ];
+
+ dontWrapQtApps = true;
+
+ installPhase = ''
+ install -Dm755 gps-whatsnew -t $out/bin
+ '';
+
+ meta = with lib; {
+ description = "Compare gpx tracks to find new segments (places never traveled before)";
+ inherit (src.meta) homepage;
+ license = licenses.gpl3Only;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.unix;
+ };
+}