commit 006ee24208080c0f1bdb75bc79da6e8814c269e7
parent cc8158ef06388e70bb1bf2ad3b2e086decd10d76
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Fri, 10 Mar 2023 23:56:42 +0400
Up
Diffstat:
3 files changed, 8 insertions(+), 4 deletions(-)
diff --git a/flake.lock b/flake.lock
@@ -17,11 +17,11 @@
},
"nixpkgs": {
"locked": {
- "lastModified": 1677852945,
- "narHash": "sha256-liiVJjkBTuBTAkRW3hrI8MbPD2ImYzwUpa7kvteiKhM=",
+ "lastModified": 1678418513,
+ "narHash": "sha256-HLLR2Fmkn3TgD0F+u5gMcTKx5YzAU1rbS4cLfm6ugiU=",
"owner": "nixos",
"repo": "nixpkgs",
- "rev": "f5ffd5787786dde3a8bf648c7a1b5f78c4e01abb",
+ "rev": "5496585eb876f2ce97654bc8f96838c6f8642563",
"type": "github"
},
"original": {
diff --git a/pkgs/mqtt/flashmq/default.nix b/pkgs/mqtt/flashmq/default.nix
@@ -11,6 +11,10 @@ stdenv.mkDerivation rec {
hash = "sha256-VikTaPczF1+Bk/K6D5lZgyLybNETtm0YTEwFgPmpiiw=";
};
+ postPatch = lib.optionalString (stdenv.isLinux && !stdenv.isx86_64) ''
+ substituteInPlace CMakeLists.txt --replace "-msse4.2" ""
+ '';
+
nativeBuildInputs = [ cmake installShellFiles ];
buildInputs = [ openssl ];
diff --git a/pkgs/radio/gqrx-scanner/default.nix b/pkgs/radio/gqrx-scanner/default.nix
@@ -13,7 +13,7 @@ stdenv.mkDerivation (finalAttrs: {
nativeBuildInputs = [ cmake ];
- NIX_CFLAGS_COMPILE = lib.optional stdenv.isDarwin "-DOSX";
+ env.NIX_CFLAGS_COMPILE = lib.optionalString stdenv.isDarwin "-DOSX";
meta = with lib; {
description = "A frequency scanner for Gqrx Software Defined Radio receiver";