commit cc8158ef06388e70bb1bf2ad3b2e086decd10d76
parent f0ba3759ca0825394bd2fda2c39835d261c56276
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Fri, 10 Mar 2023 23:41:02 +0400
Add flashmq
Diffstat:
2 files changed, 32 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -365,6 +365,7 @@ lib.makeScope newScope (
### MQTT
emitter = callPackage ./mqtt/emitter { };
+ flashmq = callPackage ./mqtt/flashmq { };
go-mqtt-to-influxdb = callPackage ./mqtt/go-mqtt-to-influxdb { };
influxdb-cxx = callPackage ./mqtt/influxdb-cxx { };
janus-mqtt-proxy = callPackage ./mqtt/janus-mqtt-proxy { };
diff --git a/pkgs/mqtt/flashmq/default.nix b/pkgs/mqtt/flashmq/default.nix
@@ -0,0 +1,31 @@
+{ lib, stdenv, fetchFromGitHub, cmake, installShellFiles, openssl }:
+
+stdenv.mkDerivation rec {
+ pname = "flashmq";
+ version = "1.3.0";
+
+ src = fetchFromGitHub {
+ owner = "halfgaar";
+ repo = "FlashMQ";
+ rev = "v${version}";
+ hash = "sha256-VikTaPczF1+Bk/K6D5lZgyLybNETtm0YTEwFgPmpiiw=";
+ };
+
+ nativeBuildInputs = [ cmake installShellFiles ];
+
+ buildInputs = [ openssl ];
+
+ installPhase = ''
+ install -Dm755 flashmq -t $out/bin
+ installManPage $src/man/*.{1,5}
+ '';
+
+ meta = with lib; {
+ description = "Fast light-weight MQTT broker/server";
+ homepage = "https://www.flashmq.org/";
+ license = licenses.agpl3;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.linux;
+ skip.ci = stdenv.isDarwin;
+ };
+}