commit fcafe760550d15479678b289fb32e033c570ebc7
parent 50d29a1fcad8f1ee808de60e124453f2808706b7
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Thu, 4 Feb 2021 22:19:01 +0300
Add render_geojson
Diffstat:
2 files changed, 26 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -152,6 +152,7 @@ lib.makeScope newScope (
gpxtrackposter = callPackage ./tools/geo/gpxtrackposter { };
lazyscraper = callPackage ./tools/text/lazyscraper { };
py-staticmaps = callPackage ./tools/geo/py-staticmaps { };
+ render_geojson = callPackage ./tools/geo/render_geojson { };
supermercado = callPackage ./tools/geo/supermercado { };
tile-stitch = callPackage ./tools/geo/tile-stitch { };
tilesets-cli = callPackage ./tools/geo/tilesets-cli { };
diff --git a/pkgs/tools/geo/render_geojson/default.nix b/pkgs/tools/geo/render_geojson/default.nix
@@ -0,0 +1,25 @@
+{ lib, stdenv, fetchFromGitHub, autoreconfHook, wxGTK30-gtk3 }:
+
+stdenv.mkDerivation {
+ pname = "render_geojson";
+ version = "2018-07-11";
+
+ src = fetchFromGitHub {
+ owner = "pedro-vicente";
+ repo = "render_geojson";
+ rev = "ed65a22f45fc09784fa113fe93254492d88663c2";
+ sha256 = "063faznw81dh4bah0hd3rl258x18cxbn88bcqdxc0avsidw7ijaz";
+ };
+
+ nativeBuildInputs = [ autoreconfHook ];
+
+ buildInputs = [ wxGTK30-gtk3 ];
+
+ meta = with lib; {
+ description = "C++ geoJSON and topoJSON parser and rendering using the WxWidgets GUI library";
+ homepage = "https://github.com/pedro-vicente/render_geojson";
+ license = licenses.asl20;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.unix;
+ };
+}