commit fb5587656ce127bee973d24c50b29892d454d962
parent 00b31a06c9375bd403e774988c2e2f7ba01a3a9d
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Thu, 16 May 2024 21:30:28 +0400
Add kealib, rsgislib
Diffstat:
3 files changed, 52 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -213,6 +213,7 @@ lib.makeScope newScope (
hecate = callPackage ./geospatial/hecate {
inherit (darwin.apple_sdk.frameworks) Security;
};
+ kealib = callPackage ./geospatial/kealib { };
localtileserver = callPackage ./geospatial/localtileserver { };
mapsoft = callPackage ./geospatial/mapsoft {
proj = pkgs.proj_7;
@@ -249,6 +250,7 @@ lib.makeScope newScope (
rio-mucho = callPackage ./geospatial/rio-mucho { };
rio-stac = callPackage ./geospatial/rio-stac { };
rio-tiler = callPackage ./geospatial/rio-tiler { };
+ rsgislib = callPackage ./geospatial/rsgislib { };
sasplanet = callPackage ./geospatial/sasplanet { };
server-thread = callPackage ./geospatial/server-thread { };
starlette-cramjam = callPackage ./geospatial/starlette-cramjam { };
diff --git a/pkgs/geospatial/kealib/default.nix b/pkgs/geospatial/kealib/default.nix
@@ -0,0 +1,25 @@
+{ lib, stdenv, fetchFromGitHub, cmake, hdf5 }:
+
+stdenv.mkDerivation rec {
+ pname = "kealib";
+ version = "1.5.3";
+
+ src = fetchFromGitHub {
+ owner = "ubarsc";
+ repo = "kealib";
+ rev = "kealib-${version}";
+ hash = "sha256-s6sL8T1jRBmVCrFm00uCw9x6s43u9+GU3ihyMi7XSaQ=";
+ };
+
+ nativeBuildInputs = [ cmake ];
+
+ buildInputs = [ hdf5 ];
+
+ meta = with lib; {
+ description = "KEALib provides an implementation of the GDAL data model";
+ homepage = "http://kealib.org/";
+ license = licenses.mit;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.unix;
+ };
+}
diff --git a/pkgs/geospatial/rsgislib/default.nix b/pkgs/geospatial/rsgislib/default.nix
@@ -0,0 +1,25 @@
+{ lib, stdenv, fetchFromGitHub, cmake, boost, gdal, gsl, hdf5, kealib, muparser, python3 }:
+
+stdenv.mkDerivation rec {
+ pname = "rsgislib";
+ version = "5.1.3";
+
+ src = fetchFromGitHub {
+ owner = "remotesensinginfo";
+ repo = "rsgislib";
+ rev = version;
+ hash = "sha256-RE5i2ULlgHEWHJIqeWNdnxtREcHrmP4dS996onJrBFk=";
+ };
+
+ nativeBuildInputs = [ cmake ];
+
+ buildInputs = [ boost gdal gsl hdf5 kealib muparser python3 ];
+
+ meta = with lib; {
+ description = "Remote Sensing and GIS Software Library";
+ homepage = "https://www.rsgislib.org/";
+ license = licenses.gpl3Plus;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.unix;
+ };
+}