commit f880b5d02deed90d3dea8adfac692c70e1c1f3aa
parent 4babbb0aebfc7937b07919ebd5d4353eb18a4f23
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Tue, 9 Jul 2024 21:14:04 +0400
Up
Diffstat:
3 files changed, 8 insertions(+), 59 deletions(-)
diff --git a/pkgs/darwin/finch/default.nix b/pkgs/darwin/finch/default.nix
@@ -3,82 +3,31 @@
stdenv,
buildGoModule,
fetchFromGitHub,
- fetchurl,
}:
-let
- arch = lib.head (lib.splitString "-" stdenv.hostPlatform.system);
- # Check LIMA_URL in Makefile
- lima =
- {
- "x86_64-darwin" = fetchurl {
- url = "https://deps.runfinch.com/${
- lib.replaceStrings [ "_" ] [ "-" ] arch
- }/lima-and-qemu.macos-${arch}.1701821611.tar.gz";
- hash = "sha256-mXBQLptj7hpPWGZXMnxDORVq3Zti/yYyW+Udm/FF9UQ=";
- };
- "aarch64-darwin" = fetchurl {
- url = "https://deps.runfinch.com/${
- lib.replaceStrings [ "_" ] [ "-" ] arch
- }/lima-and-qemu.macos-${arch}.1701821611.tar.gz";
- hash = "sha256-6Ll2CUwGJKUl8vxgdDx4Xm6O2WMYGJxMX6mLHJSvtT8=";
- };
- }
- .${stdenv.hostPlatform.system};
- # Check FINCH_OS_BASENAME in Makefile
- os =
- {
- "x86_64-darwin" = fetchurl {
- url = "https://dl.fedoraproject.org/pub/fedora/linux/releases/38/Cloud/${arch}/images/Fedora-Cloud-Base-38-1.6.${arch}.qcow2";
- hash = "sha256-0zRnBAH/PVtBKfzGYs9k9ablaCKK9ZB2zESaSUUxhII=";
- };
- "aarch64-darwin" = fetchurl {
- url = "https://dl.fedoraproject.org/pub/fedora/linux/releases/38/Cloud/${arch}/images/Fedora-Cloud-Base-38-1.6.${arch}.qcow2";
- hash = "sha256-0zRnBAH/PVtBKfzGYs9k9ablaCKK9ZB2zESaSUUxhII=";
- };
- }
- .${stdenv.hostPlatform.system};
-in
buildGoModule rec {
pname = "finch";
- version = "1.1.3";
+ version = "1.2.1";
src = fetchFromGitHub {
owner = "runfinch";
repo = "finch";
rev = "v${version}";
- hash = "sha256-K49gaN3n7wjXk3r7Rpsqd+pQYrYPuxCULo0TGDhfCsk=";
+ hash = "sha256-LtVW1HAi2oDx1MbsFnzHLZkBuYoGQs0dQU2HiWD7gB4=";
fetchSubmodules = true;
};
- vendorHash = "sha256-dyspVMmXuBHtZKk41ibcJwQMrbGNRxQwcPDeRpkr1IU=";
+ vendorHash = "sha256-7opa7lW606VZkCJR0ezzfzaPIpBsbnSoA/6I0GaPAoM=";
subPackages = [ "cmd/finch" ];
ldflags = [ "-X github.com/runfinch/finch/pkg/version.Version=${version}" ];
- doCheck = false;
-
preCheck = ''
export HOME=$TMPDIR
'';
- postInstall = ''
- mkdir -p $out/Applications/Finch/{bin,lima,os}
- mv $out/bin/finch $out/Applications/Finch/bin
- ln -s $out/Applications/Finch/bin/finch $out/bin/finch
-
- tar -xvf ${lima} -C $out/Applications/Finch/lima
- cp ${os} $out/Applications/Finch/os/${os.name}
-
- cp config.yaml $out/Applications/Finch
- cp finch.yaml $out/Applications/Finch/os
-
- substituteInPlace $out/Applications/Finch/os/finch.yaml \
- --replace-fail "<finch_image_location>" "$out/Applications/Finch/os/${os.name}" \
- --replace-fail "<finch_image_arch>" "${arch}" \
- --replace-fail "<finch_image_digest>" "sha256:$(sha256sum ${os} | cut -d' ' -f1)"
- '';
+ checkFlags = [ "-skip=TestVersionAction_run" ];
meta = {
description = "Client for container development";
diff --git a/pkgs/gemini/eva/default.nix b/pkgs/gemini/eva/default.nix
@@ -33,7 +33,7 @@ rustPlatform.buildRustPackage rec {
buildInputs = [
gtk4
openssl
- ] ++ lib.optional stdenv.isDarwin darwin.apple_sdk.frameforks.Security;
+ ] ++ lib.optional stdenv.isDarwin darwin.apple_sdk.frameworks.Security;
meta = {
description = "Gemini protocol browser written in Rust using the gtk+ toolkit";
diff --git a/pkgs/suckless/imscript/default.nix b/pkgs/suckless/imscript/default.nix
@@ -16,13 +16,13 @@
stdenv.mkDerivation (finalAttrs: {
pname = "imscript";
- version = "0-unstable-2024-07-05";
+ version = "0-unstable-2024-07-09";
src = fetchFromSourcehut {
owner = "~coco";
repo = "imscript";
- rev = "b146c88ed05988e025ec10ff1e75471c57cd2542";
- hash = "sha256-43jcjQJT/x3duP+uEUrhA/nTX+VHEDOoxtOPOqd78tQ=";
+ rev = "712e8f48f1221b382c77eb3e49535e8ae22b5bc8";
+ hash = "sha256-m8uRn3XZPliygEVmIq19n9xy2LnDlDgpkJr5n266y5Y=";
};
nativeBuildInputs = [ installShellFiles ];