commit f7f6a546267b18f07728f6e9d91bf44f8a065fee
parent b8cf308ffb30f51c54ce406f4e83ebac384be9de
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Sat, 14 Mar 2020 21:05:50 +0300
Add morse-talk
Diffstat:
3 files changed, 34 insertions(+), 0 deletions(-)
diff --git a/nix/sources.json b/nix/sources.json
@@ -335,6 +335,18 @@
"url": "https://github.com/mapbox/mercantile/archive/dae32795f9da7a9f39d8ea52f2321af008f35ab9.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
+ "morse-talk": {
+ "branch": "master",
+ "description": "A Python library written for Morse Code",
+ "homepage": "https://github.com/morse-talk/morse-talk",
+ "owner": "morse-talk",
+ "repo": "morse-talk",
+ "rev": "71e09ace0aa554d28cada5ee658e43758305b8fa",
+ "sha256": "0jnpv73q4s7x2zhpvnvxhv3bw6asnrqfr1pjr4hzsbpl7h8h5x3y",
+ "type": "tarball",
+ "url": "https://github.com/morse-talk/morse-talk/archive/71e09ace0aa554d28cada5ee658e43758305b8fa.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
"openmtbmap_openvelomap_linux": {
"branch": "master",
"builtin": false,
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -59,6 +59,9 @@ lib.makeScope newScope (self: with self; {
mercantile = python3Packages.callPackage ./development/python-modules/mercantile {
inherit sources;
};
+ morse-talk = python3Packages.callPackage ./tools/morse-talk {
+ inherit sources;
+ };
openmtbmap_openvelomap_linux = callPackage ./tools/geo/openmtbmap_openvelomap_linux { };
openorienteering-mapper = libsForQt5.callPackage ./applications/openorienteering-mapper {
inherit sources;
diff --git a/pkgs/tools/morse-talk/default.nix b/pkgs/tools/morse-talk/default.nix
@@ -0,0 +1,19 @@
+{ lib, buildPythonApplication, matplotlib, nose, sounddevice, sources }:
+
+buildPythonApplication rec {
+ pname = "morse-talk";
+ version = lib.substring 0 7 src.rev;
+ src = sources.morse-talk;
+
+ propagatedBuildInputs = [ matplotlib sounddevice ];
+
+ checkInputs = [ nose ];
+ checkPhase = "nosetests";
+
+ meta = with lib; {
+ inherit (src) description homepage;
+ license = licenses.gpl2;
+ maintainers = with maintainers; [ sikmir ];
+ platforms = platforms.unix;
+ };
+}