commit f7586b4709cd251b3369f16984426be461ff83c5
parent 50dae274bdbdf7b0f7e65b01da3cd99cac01337b
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Sun, 12 Jul 2020 00:13:31 +0300
Add visualgps
Diffstat:
2 files changed, 40 insertions(+), 0 deletions(-)
diff --git a/pkgs/applications/visualgps/default.nix b/pkgs/applications/visualgps/default.nix
@@ -0,0 +1,39 @@
+{ stdenv
+, mkDerivation
+, fetchFromGitHub
+, qmake
+, qtserialport
+}:
+
+mkDerivation {
+ pname = "visualgps";
+ version = "unstable-2020-03-29";
+
+ src = fetchFromGitHub {
+ owner = "VisualGPS";
+ repo = "VisualGPSqt";
+ rev = "f2e213208a48e1f7d7294bc832a848de4efb4fd4";
+ sha256 = "0f66xaisvgrjd25129li4lbp34d2hmw49i44vqq06hinjvpma7yp";
+ fetchSubmodules = true;
+ };
+
+ nativeBuildInputs = [ qmake ];
+
+ buildInputs = [ qtserialport ];
+
+ qmakeFlags = [ "Software/VisualGPSqt/Source/VisualGPSqt.pro" ];
+
+ postInstall = stdenv.lib.optionalString stdenv.isDarwin ''
+ mkdir -p $out/Applications
+ mv VisualGPSqt.app $out/Applications
+ wrapQtApp $out/Applications/VisualGPSqt.app/Contents/MacOS/VisualGPSqt
+ '';
+
+ meta = with stdenv.lib; {
+ description = "A QT application (GUI) that makes use of the VisualGPS/NMEAParser project";
+ homepage = "https://github.com/VisualGPS/VisualGPSqt";
+ license = licenses.mit;
+ maintainers = with maintainers; [ sikmir ];
+ platforms = with platforms; linux ++ darwin;
+ };
+}
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -26,6 +26,7 @@ lib.makeScope newScope (
redict = libsForQt5.callPackage ./applications/redict {
inherit sources;
};
+ visualgps = libsForQt5.callPackage ./applications/visualgps { };
wireguard-statusbar = callPackage ./applications/wireguard-statusbar { };
### BUILD SUPPORT