commit f4ef8d1b0c092b01340def8a77496ef4f8df29c7
parent 7a79829693362eb0b9d2c065beb154b6d28df097
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Fri, 31 Mar 2023 23:10:28 +0400
Add macsvg
Diffstat:
2 files changed, 33 insertions(+), 0 deletions(-)
diff --git a/pkgs/darwin/macsvg/default.nix b/pkgs/darwin/macsvg/default.nix
@@ -0,0 +1,32 @@
+{ lib, stdenv, fetchfromgh, unzip }:
+
+stdenv.mkDerivation (finalAttrs: {
+ pname = "macsvg-bin";
+ version = "1.2.0";
+
+ src = fetchfromgh {
+ owner = "dsward2";
+ repo = "macSVG";
+ name = "macSVG-v${lib.versions.majorMinor finalAttrs.version}.zip";
+ hash = "sha256-wlEFUzFQ9fnSjmsIrCDzRvSZmfcK9V+go6pNYJOqN+w=";
+ version = "v${finalAttrs.version}";
+ };
+
+ sourceRoot = ".";
+
+ nativeBuildInputs = [ unzip ];
+
+ installPhase = ''
+ mkdir -p $out/Applications
+ cp -r macSVG_v${lib.replaceStrings [ "." ] [ "_" ] (lib.versions.majorMinor finalAttrs.version)}/*.app $out/Applications
+ '';
+
+ meta = with lib; {
+ description = "An open-source macOS app for designing HTML5 SVG";
+ homepage = "https://macsvg.org/";
+ license = licenses.mit;
+ maintainers = [ maintainers.sikmir ];
+ platforms = [ "aarch64-darwin" "x86_64-darwin" ];
+ skip.ci = true;
+ };
+})
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -31,6 +31,7 @@ lib.makeScope newScope (
buildGoModule = pkgs.buildGo120Module;
};
macpass-bin = callPackage ./darwin/macpass/bin.nix { };
+ macsvg-bin = callPackage ./darwin/macsvg { };
marta-bin = callPackage ./darwin/marta { };
pinentry-touchid = callPackage ./darwin/pinentry-touchid {
inherit (darwin.apple_sdk.frameworks) LocalAuthentication;