commit f2311cbe1ba5ffa964cd3a81174e6ba0953da7b8
parent 490e904ba44fb32053e5a19469e36c72a2ca6781
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Fri, 16 Aug 2024 02:23:15 +0400
Add hardpy
Diffstat:
2 files changed, 49 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -101,6 +101,7 @@ lib.makeScope newScope (
earthpy = callPackage ./development/python-modules/earthpy { };
geotiler = callPackage ./development/python-modules/geotiler { };
gpxelevations = callPackage ./development/python-modules/gpxelevations { };
+ hardpy = callPackage ./development/python-modules/hardpy { };
jsonseq = callPackage ./development/python-modules/jsonseq { };
modbus_tk = callPackage ./development/python-modules/modbus_tk {
python3Packages = pkgs.python310Packages;
diff --git a/pkgs/development/python-modules/hardpy/default.nix b/pkgs/development/python-modules/hardpy/default.nix
@@ -0,0 +1,48 @@
+{
+ lib,
+ python3Packages,
+ fetchFromGitHub,
+ pycouchdb,
+}:
+
+python3Packages.buildPythonPackage rec {
+ pname = "hardpy";
+ version = "0.4.0";
+ pyproject = true;
+ disabled = python3Packages.pythonOlder "3.10";
+
+ src = fetchFromGitHub {
+ owner = "everypinio";
+ repo = "hardpy";
+ rev = version;
+ hash = "sha256-CVn5Edon1auXNFFNRGnt2i1j9TJo+uX194a22tIQpVE=";
+ };
+
+ postPatch = ''
+ substituteInPlace pyproject.toml \
+ --replace-fail "hatchling==1.21.1" "hatchling"
+ '';
+
+ build-system = with python3Packages; [ hatchling ];
+
+ dependencies = with python3Packages; [
+ pycouchdb
+ glom
+ pydantic
+ natsort
+ fastapi
+ uvicorn
+ pytest
+ ];
+
+ doCheck = false;
+
+ nativeCheckInputs = with python3Packages; [ pytestCheckHook ];
+
+ meta = {
+ description = "HardPy library for device testing";
+ homepage = "https://everypinio.github.io/hardpy/";
+ license = lib.licenses.gpl3Plus;
+ maintainers = [ lib.maintainers.sikmir ];
+ };
+}