commit f1b7170f5f0e0fc40ae560544e4abe2b987bcb0e
parent 59dc774f0dfd1b5973e912d454ca08924b71374f
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Sun, 1 Aug 2021 14:52:52 +0300
Up
Diffstat:
3 files changed, 8 insertions(+), 9 deletions(-)
diff --git a/pkgs/applications/gpxsee/bin.nix b/pkgs/applications/gpxsee/bin.nix
@@ -2,11 +2,11 @@
stdenv.mkDerivation rec {
pname = "gpxsee-bin";
- version = "9.0";
+ version = "9.3";
src = fetchurl {
url = "mirror://sourceforge/gpxsee/GPXSee-${version}.dmg";
- hash = "sha256-9QZdQPPg/Cl7fjM6ucGnno6HNQnkdEtAFnVTH66KSjI=";
+ hash = "sha256-H0PvH1UCwBNGdIwFJcT2dJtDIKyNbHGWC5aD1eOzFiE";
};
preferLocalBuild = true;
diff --git a/pkgs/gpx/gpxtools/default.nix b/pkgs/gpx/gpxtools/default.nix
@@ -23,9 +23,8 @@ stdenv.mkDerivation {
meta = with lib; {
description = "A collection of c++ tools for using GPX files";
homepage = "https://notabug.org/irdvo/gpxtools";
- license = licenses.gpl3;
+ license = licenses.gpl3Only;
maintainers = [ maintainers.sikmir ];
platforms = platforms.unix;
- broken = stdenv.isDarwin; # https://github.com/NixOS/nixpkgs/pull/127172
};
}
diff --git a/pkgs/misc/yabai/default.nix b/pkgs/misc/yabai/default.nix
@@ -1,23 +1,23 @@
-{ lib, stdenv, fetchFromGitHub, Cocoa, ScriptingBridge, xxd }:
+{ lib, stdenv, fetchFromGitHub, Cocoa, ScriptingBridge, installShellFiles, xxd }:
stdenv.mkDerivation rec {
pname = "yabai";
- version = "3.3.7";
+ version = "3.3.10";
src = fetchFromGitHub {
owner = "koekeishiya";
repo = pname;
rev = "v${version}";
- sha256 = "1yx4qp4rwk3ncw57yqy9m0nsg1rb62x4y2mj009lbzx0syfvh84s";
+ hash = "sha256-8O6//T894C32Pba3F2Z84Z6VWeCXlwml3xsXoIZGqL0";
};
- nativeBuildInputs = [ xxd ];
+ nativeBuildInputs = [ installShellFiles xxd ];
buildInputs = [ Cocoa ScriptingBridge ];
postInstall = ''
install -Dm755 bin/yabai -t $out/bin
- install -Dm644 doc/yabai.1 -t $out/share/man/man1
+ installManPage doc/yabai.1
'';
meta = with lib; {