commit ee1d99ad0afb6599a91029795f17e65777da2767
parent d22d2d791027d0820509aab8b92026e2bb1be226
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Tue, 21 Jul 2020 21:06:22 +0300
openorienteering-mapper: add patch
Diffstat:
2 files changed, 33 insertions(+), 5 deletions(-)
diff --git a/pkgs/applications/openorienteering-mapper/add-nakarte-link.patch b/pkgs/applications/openorienteering-mapper/add-nakarte-link.patch
@@ -0,0 +1,24 @@
+diff --git i/src/gui/georeferencing_dialog.cpp w/src/gui/georeferencing_dialog.cpp
+index bcec0943..b2d6ae70 100644
+--- i/src/gui/georeferencing_dialog.cpp
++++ w/src/gui/georeferencing_dialog.cpp
+@@ -394,15 +394,12 @@ void GeoreferencingDialog::projectionChanged()
+ double longitude = latlon.longitude();
+ setValueIfChanged(lat_edit, latitude);
+ setValueIfChanged(lon_edit, longitude);
+- QString osm_link =
+- QString::fromLatin1("http://www.openstreetmap.org/?lat=%1&lon=%2&zoom=18&layers=M").
+- arg(latitude).arg(longitude);
+- QString worldofo_link =
+- QString::fromLatin1("http://maps.worldofo.com/?zoom=15&lat=%1&lng=%2").
++ QString nakarte_link =
++ QString::fromLatin1("https://nakarte.me/#m=18/%1/%2&l=O/U/R").
+ arg(latitude).arg(longitude);
+ link_label->setText(
+- tr("<a href=\"%1\">OpenStreetMap</a> | <a href=\"%2\">World of O Maps</a>").
+- arg(osm_link, worldofo_link)
++ tr("<a href=\"%1\">nakarte.me</a>").
++ arg(nakarte_link)
+ );
+
+ QString error = georef->getErrorText();
diff --git a/pkgs/applications/openorienteering-mapper/default.nix b/pkgs/applications/openorienteering-mapper/default.nix
@@ -27,11 +27,15 @@ mkDerivation {
inherit pname version;
src = sources.mapper;
- patches = (substituteAll {
- # See https://github.com/NixOS/nixpkgs/issues/86054
- src = ./fix-qttranslations-path.patch;
- inherit qttranslations;
- });
+ patches = [
+ (substituteAll {
+ # See https://github.com/NixOS/nixpkgs/issues/86054
+ src = ./fix-qttranslations-path.patch;
+ inherit qttranslations;
+ })
+ # See https://github.com/OpenOrienteering/mapper/issues/1042
+ ./add-nakarte-link.patch
+ ];
buildInputs = [
gdal