commit ec31aa94b683375ade1c792a76397072e7357088
parent 1f9223bb9cd00841e0c91672dd7ffa0ceb3bff96
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Wed, 12 Feb 2020 00:38:55 +0300
Move ueberzug to nixpkgs
Diffstat:
3 files changed, 0 insertions(+), 35 deletions(-)
diff --git a/default.nix b/default.nix
@@ -127,7 +127,4 @@ in stdenv.lib.makeScope pkgs.newScope (self: with self; {
tpkutils = python3Packages.callPackage ./pkgs/tools/tpkutils {
inherit (sources) tpkutils;
};
- ueberzug = python3Packages.callPackage ./pkgs/tools/ueberzug {
- inherit (sources) ueberzug;
- };
})
diff --git a/nix/sources.json b/nix/sources.json
@@ -401,18 +401,5 @@
"type": "tarball",
"url": "https://github.com/consbio/tpkutils/archive/5aec5e5a996b16575812d90586a5cd1e865437bf.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
- },
- "ueberzug": {
- "branch": "master",
- "builtin": false,
- "description": "ueberzug is an alternative for w3mimgdisplay",
- "homepage": "https://github.com/seebye/ueberzug",
- "owner": "seebye",
- "repo": "ueberzug",
- "rev": "6f488070a8eda856289f19b70604c0f80ffd5bf0",
- "sha256": "1cliar6vsbc2mlrpigk6j13i20832giprargggb5ivscmfakywi8",
- "type": "tarball",
- "url": "https://github.com/seebye/ueberzug/archive/6f488070a8eda856289f19b70604c0f80ffd5bf0.tar.gz",
- "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
}
}
diff --git a/pkgs/tools/ueberzug/default.nix b/pkgs/tools/ueberzug/default.nix
@@ -1,19 +0,0 @@
-{ lib, buildPythonApplication, libX11, libXext, xlib, pillow, docopt, psutil
-, attrs, ueberzug }:
-
-buildPythonApplication rec {
- pname = "ueberzug";
- version = lib.substring 0 7 src.rev;
- src = ueberzug;
-
- buildInputs = [ libX11 libXext ];
- propagatedBuildInputs = [ xlib pillow docopt psutil attrs ];
-
- meta = with lib; {
- description = ueberzug.description;
- homepage = ueberzug.homepage;
- license = licenses.gpl3;
- maintainers = with maintainers; [ sikmir ];
- platforms = platforms.unix;
- };
-}