commit ebbc17be60d9c407cfc6289d0369000694c57781
parent d82de50f018c47bff8d3b9ca5a176618114034eb
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Fri, 14 Mar 2025 19:15:50 +0400
Up
Diffstat:
5 files changed, 14 insertions(+), 10 deletions(-)
diff --git a/pkgs/darwin/qtcreator/bin.nix b/pkgs/darwin/qtcreator/bin.nix
@@ -9,13 +9,13 @@
stdenv.mkDerivation (finalAttrs: {
pname = "qtcreator-bin";
- version = "15.0.1";
+ version = "16.0.0";
src = fetchfromgh {
owner = "qt-creator";
repo = "qt-creator";
tag = "v${finalAttrs.version}";
- hash = "sha256-64pmcCvqBnohrmYw+VLUWskOhzmWd9aWZXzFhqG1I9o=";
+ hash = "sha256-kN56gLnbttaQiCTSLJawbZUTofHWLOBaNxe5ga/Pa/Q=";
name = "qtcreator-macos-universal-${finalAttrs.version}.7z";
};
diff --git a/pkgs/darwin/zed/default.nix b/pkgs/darwin/zed/default.nix
@@ -7,11 +7,11 @@
stdenvNoCC.mkDerivation (finalAttrs: {
pname = "zed";
- version = "0.178.0-pre";
+ version = "0.178.1-pre";
src = fetchurl {
url = "https://zed.dev/api/releases/stable/${finalAttrs.version}/Zed-x86_64.dmg";
- hash = "sha256-8Qt1rEcMll5eM0TyIi66zSOPy6Qz5wHLBoluTdMpoLc=";
+ hash = "sha256-Uj90ZTb6gHIMg/V9txwOFAVXKmmF44LrtHXRICLylzA=";
};
sourceRoot = ".";
diff --git a/pkgs/data/maps/opentopomap/default.nix b/pkgs/data/maps/opentopomap/default.nix
@@ -9,7 +9,7 @@
mkgmap-splitter,
}:
let
- version = "250307";
+ version = "250313";
bounds = fetchwebarchive {
url = "https://www.thkukuk.de/osm/data/bounds-20250110.zip";
timestamp = "20250116113456";
@@ -22,7 +22,7 @@ let
};
armenia = fetchurl {
url = "https://download.geofabrik.de/asia/armenia-${version}.osm.pbf";
- hash = "sha256-mW9Waomb5kbIMnulTwrpLvVFVWZMGqvHsXQNh6/IWzM=";
+ hash = "sha256-m34nbiWDNjTgM7eABt1ub+YtvvGCHyZt9KEjJ4QC42A=";
};
in
stdenv.mkDerivation (finalAttrs: {
diff --git a/pkgs/development/libraries/lunasvg/default.nix b/pkgs/development/libraries/lunasvg/default.nix
@@ -8,15 +8,19 @@
stdenv.mkDerivation (finalAttrs: {
pname = "lunasvg";
- version = "3.2.0";
+ version = "3.2.1";
src = fetchFromGitHub {
owner = "sammycage";
repo = "lunasvg";
tag = "v${finalAttrs.version}";
- hash = "sha256-/DEyiHlZJYctkNqjQECKRbMGwUYTJHtlQrO0aBXf+Oc=";
+ hash = "sha256-CBhz117Y8e7AdD1JJtNkR/EthsfyiQ05HW41beaY95I=";
};
+ postPatch = ''
+ substituteInPlace CMakeLists.txt --replace-fail "plutovg 0.0.4" "plutovg"
+ '';
+
nativeBuildInputs = [ cmake ];
buildInputs = [ plutovg ];
diff --git a/pkgs/development/libraries/plutovg/default.nix b/pkgs/development/libraries/plutovg/default.nix
@@ -7,13 +7,13 @@
stdenv.mkDerivation (finalAttrs: {
pname = "plutovg";
- version = "0.0.13";
+ version = "1.0.0";
src = fetchFromGitHub {
owner = "sammycage";
repo = "plutovg";
tag = "v${finalAttrs.version}";
- hash = "sha256-zmF64qpOwL3QHfp1GznN4TDydjGyhw8IgXYlpCEGXHg=";
+ hash = "sha256-xNWwACKGU5UIJviVZ3wU4GMuRxKn/rR8jBsZQpZiFZ8=";
};
nativeBuildInputs = [ cmake ];