commit ea47e7b643b0da73f423771b38a450a42bf59c18
parent b7024efaa52c32e490595e9417e80aeb4950542a
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Mon, 1 Feb 2021 02:08:31 +0300
Remove supload
Diffstat:
3 files changed, 0 insertions(+), 42 deletions(-)
diff --git a/nix/sources.json b/nix/sources.json
@@ -1063,20 +1063,6 @@
"url": "https://github.com/mapbox/supermercado/archive/ecc9f5a36c1c8d13872df5bdcbd01621e5f3ab48.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
- "supload": {
- "branch": "master",
- "builtin": false,
- "date": "2015-08-04T11:30:01Z",
- "description": "Bash script for upload file to cloud storage based on OpenStack Swift API",
- "homepage": "https://github.com/selectel/supload",
- "owner": "selectel",
- "repo": "supload",
- "rev": "70690682867713c68d7c6daa833a1013e79df407",
- "sha256": "0di1hr9j2wdicj6n2mlf9achfxd05rqwrfnymsnxhhy7sv50n2bm",
- "type": "tarball",
- "url": "https://github.com/selectel/supload/archive/70690682867713c68d7c6daa833a1013e79df407.tar.gz",
- "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
- },
"tatoebatools": {
"branch": "master",
"builtin": false,
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -236,7 +236,6 @@ lib.makeScope newScope (
inherit sources;
};
ptunnel = callPackage ./misc/ptunnel { };
- supload = callPackage ./misc/supload { };
taskcoach = callPackage ./misc/taskcoach { };
xfractint = callPackage ./misc/xfractint { };
diff --git a/pkgs/misc/supload/default.nix b/pkgs/misc/supload/default.nix
@@ -1,27 +0,0 @@
-{ stdenv, curl, file, coreutils, sources }:
-
-stdenv.mkDerivation {
- pname = "supload-unstable";
- version = stdenv.lib.substring 0 10 sources.supload.date;
-
- src = sources.supload;
-
- buildInputs = [ curl file ];
-
-
- prePatch = ''
- substituteInPlace supload.sh \
- --replace '`which curl`' '${curl}/bin/curl' \
- --replace '`which file`' '${file}/bin/file' \
- --replace '`which md5sum`' '${coreutils}/bin/md5sum'
- '';
-
- installPhase = "install -Dm755 supload.sh $out/bin/supload";
-
- meta = with stdenv.lib; {
- inherit (sources.supload) description homepage;
- license = licenses.gpl3;
- maintainers = [ maintainers.sikmir ];
- platforms = platforms.unix;
- };
-}