commit e828e14fb6a8929ead489ee0d2e1532f73d9f440
parent 854b937fe3499676a8fec9de723c820a798a5c6c
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 22 May 2022 23:22:40 +0300
Add server-thread
Diffstat:
2 files changed, 25 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -194,6 +194,7 @@ lib.makeScope newScope (
rio-tiler = callPackage ./geospatial/rio-tiler { };
sasplanet-bin = callPackage ./geospatial/sasplanet/bin.nix { };
scooby = callPackage ./geospatial/scooby { };
+ server-thread = callPackage ./geospatial/server-thread { };
starlette-cramjam = callPackage ./geospatial/starlette-cramjam { };
supermercado = callPackage ./geospatial/supermercado { };
tdh = callPackage ./geospatial/tdh { };
diff --git a/pkgs/geospatial/server-thread/default.nix b/pkgs/geospatial/server-thread/default.nix
@@ -0,0 +1,24 @@
+{ lib, python3Packages, fetchFromGitHub, scooby }:
+
+python3Packages.buildPythonPackage rec {
+ pname = "server-thread";
+ version = "0.1.0";
+
+ src = fetchFromGitHub {
+ owner = "banesullivan";
+ repo = pname;
+ rev = version;
+ hash = "sha256-EAL/moz3AIPBRLfAVI2zcCstjLsssKqBrxIDvq9CV3g=";
+ };
+
+ propagatedBuildInputs = with python3Packages; [ scooby werkzeug ];
+
+ checkInputs = with python3Packages; [ flask requests pytestCheckHook ];
+
+ meta = with lib; {
+ description = "Launch a WSGIApplication in a background thread with werkzeug";
+ inherit (src.meta) homepage;
+ license = licenses.mit;
+ maintainers = [ maintainers.sikmir ];
+ };
+}