commit e15ed963a2440b0906de7cc0bfd835fe00e1dc80
parent f49be841f012c48e3c40b672371967db28e20cb6
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 14 May 2023 22:02:32 +0400
tirex: fix build
Diffstat:
1 file changed, 36 insertions(+), 2 deletions(-)
diff --git a/pkgs/osm/tirex/default.nix b/pkgs/osm/tirex/default.nix
@@ -1,4 +1,20 @@
-{ lib, stdenv, fetchFromGitHub, makeWrapper, cairo, mapnik, perl, perlPackages }:
+{ lib
+, stdenv
+, fetchFromGitHub
+, fetchpatch
+, makeWrapper
+, boost
+, cairo
+, harfbuzz
+, icu
+, libtiff
+, libwebp
+, mapnik
+, perl
+, perlPackages
+, proj
+, sqlite
+}:
stdenv.mkDerivation (finalAttrs: {
pname = "tirex";
@@ -11,6 +27,13 @@ stdenv.mkDerivation (finalAttrs: {
hash = "sha256-0QbPfCPBdNBbUiZ8Ppg2zao98+Ddl3l+yX6y1/J50rg=";
};
+ patches = [
+ (fetchpatch {
+ url = "https://github.com/openstreetmap/tirex/pull/54/commits/da0c5db926bc0939c53dd902a969b689ccf9edde.patch";
+ hash = "sha256-bnL1ZGy8ZNSZuCRbZn59qRVLg3TL0GjFYnhRKroeVO0=";
+ })
+ ];
+
postPatch = ''
substituteInPlace Makefile --replace "/usr" "" --replace ": Makefile.perl" ":"
substituteInPlace backend-mapnik/Makefile --replace "/usr" ""
@@ -23,7 +46,18 @@ stdenv.mkDerivation (finalAttrs: {
nativeBuildInputs = [ makeWrapper ];
- buildInputs = [ cairo mapnik perl ];
+ buildInputs = [
+ boost
+ cairo
+ harfbuzz
+ icu
+ libtiff
+ libwebp
+ mapnik
+ perl
+ proj
+ sqlite
+ ];
installFlags = [ "DESTDIR=$(out)" "INSTALLOPTS:=" ];