commit e13ae41eaabe22097bb2385c877bd751a5e627e4
parent f2207a8c077cd874ef79401507e583c97ff11401
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Wed, 10 Nov 2021 20:33:39 +0300
rio-mbtiles: fix build
Diffstat:
1 file changed, 5 insertions(+), 2 deletions(-)
diff --git a/pkgs/geospatial/rio-mbtiles/default.nix b/pkgs/geospatial/rio-mbtiles/default.nix
@@ -11,6 +11,11 @@ python3Packages.buildPythonApplication rec {
hash = "sha256-Kje443Qqs8+Jcv3PnTrMncaoaGDdjrzTcd42NYIenuU=";
};
+ postPatch = ''
+ substituteInPlace setup.py \
+ --replace "shapely~=1.7.0" "shapely"
+ '';
+
propagatedBuildInputs = with python3Packages; [
click
cligj
@@ -23,8 +28,6 @@ python3Packages.buildPythonApplication rec {
checkInputs = with python3Packages; [ pytestCheckHook ];
- disabledTests = [ "test_cutline_progress_bar" ];
-
meta = with lib; {
description = "A plugin command for the Rasterio CLI that exports a raster dataset to an MBTiles 1.1 SQLite file";
inherit (src.meta) homepage;