commit dd73a131645d4faf1c3bb000d87249e396718682
parent 14e29f1d7220396fc3d041821f3e2622bf91c17c
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Sun, 28 Jun 2020 16:40:06 +0300
Add musig
Diffstat:
3 files changed, 39 insertions(+), 0 deletions(-)
diff --git a/nix/sources.json b/nix/sources.json
@@ -434,6 +434,19 @@
"url_template": "https://kartat-dl.hylly.org/<version>/mtk_suomi.img",
"version": "2020-05-30"
},
+ "musig": {
+ "branch": "master",
+ "builtin": false,
+ "description": "A shazam like tool to store musics fingerprints and retrieve them",
+ "homepage": "https://github.com/sfluor/musig",
+ "owner": "sfluor",
+ "repo": "musig",
+ "rev": "f445fa128b826c1cee527afdcc97e3e1e8433c32",
+ "sha256": "1h201rqn74hcspxjigq50vj4rl526x8s0sx18j5gbswisf84bgql",
+ "type": "tarball",
+ "url": "https://github.com/sfluor/musig/archive/f445fa128b826c1cee527afdcc97e3e1e8433c32.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
"nakarte": {
"branch": "master",
"builtin": false,
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -134,6 +134,7 @@ lib.makeScope newScope (
morse-talk = python3Packages.callPackage ./tools/morse-talk {
inherit sources;
};
+ musig = callPackage ./tools/audio/musig {};
ocad2img = perlPackages.callPackage ./tools/geo/ocad2img {
inherit cgpsmapper ocad2mp;
};
diff --git a/pkgs/tools/audio/musig/default.nix b/pkgs/tools/audio/musig/default.nix
@@ -0,0 +1,25 @@
+{ lib, buildGoModule, pkgconfig, portaudio, sources }:
+
+buildGoModule rec {
+ pname = "musig";
+ version = lib.substring 0 7 src.rev;
+ src = sources.musig;
+
+ vendorSha256 = "0ha1xjdwibm8543b4bx0xrbigngiiakksdc6mnp0mz5y6ai56pg5";
+
+ nativeBuildInputs = [ pkgconfig ];
+
+ buildInputs = [ portaudio ];
+
+ buildFlagsArray = ''
+ -ldflags=
+ -X main.VERSION=${version}
+ '';
+
+ meta = with lib; {
+ inherit (src) description homepage;
+ license = licenses.mit;
+ maintainers = with maintainers; [ sikmir ];
+ platforms = platforms.unix;
+ };
+}