commit dca7910e4b00ef4c5b6a72ece7329d295ba1172c
parent 007043ce740b2f071f87da5bd730a2bb4bca065c
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Mon, 15 Aug 2022 11:10:01 +0300
gemini-ipfs-gateway: broken on darwin
Diffstat:
1 file changed, 6 insertions(+), 5 deletions(-)
diff --git a/pkgs/gemini/gemini-ipfs-gateway/default.nix b/pkgs/gemini/gemini-ipfs-gateway/default.nix
@@ -1,17 +1,17 @@
-{ lib, buildGoModule, fetchFromSourcehut, scdoc }:
+{ lib, stdenv, buildGoModule, fetchFromSourcehut, scdoc }:
buildGoModule rec {
pname = "gemini-ipfs-gateway";
- version = "2021-03-23";
+ version = "2022-07-06";
src = fetchFromSourcehut {
owner = "~hsanjuan";
repo = pname;
- rev = "918ef8ab2691cb7af7048c9ca3d2015b6ad45f91";
- hash = "sha256-ERRqeSDnAkhjlcOYS6CBP+/YZBGXoCtjGOlcmdYjLhI=";
+ rev = "fc646a2089758c1af9aba790a991c19a2e6b37e8";
+ hash = "sha256-50viZnrgrxXNmpmfV1NQn/QTAlSEO505jbz1pzPfypA=";
};
- vendorSha256 = "sha256-LKJb3YpnydkPHSCR3ioTRDWW5R+HucY8tPfqOuS06h0=";
+ vendorSha256 = "sha256-nSeVJrQKbUHhLPggIfir+YGoXuMLwmon+ZgJHfNNqdM=";
meta = with lib; {
description = "IPFS access over the Gemini protocol";
@@ -19,5 +19,6 @@ buildGoModule rec {
license = licenses.agpl3Only;
maintainers = [ maintainers.sikmir ];
platforms = platforms.unix;
+ broken = stdenv.isDarwin;
};
}