commit d97a5cc09fe7c08f16a0b7d791e40c90a9dae465
parent 0391d0641429545fc587c2cbccbcda1f476a1174
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Wed, 19 May 2021 17:16:51 +0300
Up
Diffstat:
2 files changed, 39 insertions(+), 5 deletions(-)
diff --git a/pkgs/suckless/sfm/config.patch b/pkgs/suckless/sfm/config.patch
@@ -0,0 +1,33 @@
+diff --git i/config.def.h w/config.def.h
+index cc848c8..1005815 100644
+--- i/config.def.h
++++ w/config.def.h
+@@ -34,6 +34,8 @@ static const char *mupdf[] = { "mupdf", "-I", NULL };
+ static const char *libreoffice[] = { "libreoffice", NULL };
+ static const char *gimp[] = { "gimp", NULL };
+ static const char *r2[] = { "r2", "-c", "vv", NULL };
++static const char *gpxsee[] = { "gpxsee", NULL };
++static const char *oomapper[] = { "Mapper", NULL };
+
+ /* extensions*/
+ static const char *images[] = { "bmp", "jpg", "jpeg", "png", "gif", "xpm" };
+@@ -46,6 +48,9 @@ static const char *videos[] = { "avi", "flv", "wav", "webm", "wma", "wmv",
+ "mp4", "mpeg", "mpg" };
+ static const char *documents[] = { "odt", "doc", "docx", "xls", "xlsx", "odp",
+ "ods", "pptx", "odg" };
++static const char *gpsdata[] = { "gpx", "tcx", "kml", "loc", "slf", "fit", "igc", "nmea", "plt", "rte", "wpt", "geojson", "cup", "gpi", "sml", "ov2", "itn" };
++static const char *maps[] = { "img", "jnx", "xml", "kap", "map", "mbtiles", "rmap", "rtmap", "tba", "kmz", "aqm", "sqlitedb" };
++static const char *omaps[] = { "omap", "xmap", "ocd" };
+
+ static Rule rules[] = {
+ {videos, LEN(videos), mpv},
+@@ -55,6 +60,9 @@ static Rule rules[] = {
+ {documents, LEN(documents), libreoffice},
+ {arts, LEN(arts), gimp},
+ {obj, LEN(obj), r2},
++ {gpsdata, LEN(gpsdata), gpxsee},
++ {maps, LEN(maps), gpxsee},
++ {omaps, LEN(omaps), oomapper},
+ };
+
+ /* normal keys */
diff --git a/pkgs/suckless/sfm/default.nix b/pkgs/suckless/sfm/default.nix
@@ -2,15 +2,17 @@
stdenv.mkDerivation rec {
pname = "sfm";
- version = "2021-05-16";
+ version = "2021-05-17";
src = fetchFromGitHub {
owner = "afify";
repo = pname;
- rev = "cc1efcf914bbfe75cbd2ce2a1a90e764d5b88bfd";
- hash = "sha256-6pdxfRhvZDde332BFIYlcia5JVMS79HlgEZ/T5CniZo=";
+ rev = "e66240c2769b4a3980808e80e0505e6696a4fc06";
+ hash = "sha256-FmKdir+KL0rtKTXGI9EF5njfcBVtNC/Es+OluSmlW6w=";
};
+ patches = [ ./config.patch ];
+
configFile = lib.optionalString (conf!=null) (lib.writeText "config.def.h" conf);
postPatch = lib.optionalString (conf!=null) "cp ${configFile} config.def.h";
@@ -21,8 +23,7 @@ stdenv.mkDerivation rec {
description = "Simple file manager";
inherit (src.meta) homepage;
license = licenses.isc;
- platforms = platforms.linux;
+ platforms = platforms.unix;
maintainers = [ maintainers.sikmir ];
- skip.ci = stdenv.isDarwin;
};
}