commit d8c3e807100211af098b8836db06a66a86eb1e2f
parent 375453f4b591e30c7c72dc87c3727e915b4d336e
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Fri, 24 Jul 2020 18:18:23 +0300
add how-to-use-pvs-studio-free
Diffstat:
3 files changed, 39 insertions(+), 0 deletions(-)
diff --git a/nix/sources.json b/nix/sources.json
@@ -344,6 +344,20 @@
"url": "https://github.com/hfst/hfst/archive/a140e2868c15e9987d651aa3e6b344ec20ef3a33.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
+ "how-to-use-pvs-studio-free": {
+ "branch": "master",
+ "builtin": false,
+ "date": "2020-02-10T14:21:35Z",
+ "description": "How to use PVS-Studio for Free",
+ "homepage": "https://www.viva64.com/en/b/0457/",
+ "owner": "viva64",
+ "repo": "how-to-use-pvs-studio-free",
+ "rev": "182a5e730128755b12f44f39d8254e88397c9cce",
+ "sha256": "0rgpi6lrgka8s8xzx35qlgphp4z5449k7zs6hswl1q7w1kfh4flj",
+ "type": "tarball",
+ "url": "https://github.com/viva64/how-to-use-pvs-studio-free/archive/182a5e730128755b12f44f39d8254e88397c9cce.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
"jsonseq": {
"branch": "master",
"builtin": false,
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -67,6 +67,7 @@ lib.makeScope newScope (
### DEVELOPMENT / TOOLS
gef = callPackage ./development/tools/gef { };
+ how-to-use-pvs-studio-free = callPackage ./development/tools/pvs-studio/how-to-use-pvs-studio-free.nix { };
pvs-studio = callPackage ./development/tools/pvs-studio { };
### DEVELOPMENT / LIBRARIES
diff --git a/pkgs/development/tools/pvs-studio/how-to-use-pvs-studio-free.nix b/pkgs/development/tools/pvs-studio/how-to-use-pvs-studio-free.nix
@@ -0,0 +1,24 @@
+{ stdenv, cmake, sources }:
+let
+ pname = "how-to-use-pvs-studio-free";
+ date = stdenv.lib.substring 0 10 sources.how-to-use-pvs-studio-free.date;
+ version = "unstable-" + date;
+in
+stdenv.mkDerivation {
+ inherit pname version;
+ src = sources.how-to-use-pvs-studio-free;
+
+ nativeBuildInputs = [ cmake ];
+
+ postPatch = stdenv.lib.optionalString stdenv.cc.isClang ''
+ substituteInPlace CMakeLists.txt \
+ --replace "stdc++fs" "c++fs"
+ '';
+
+ meta = with stdenv.lib; {
+ inherit (sources.how-to-use-pvs-studio-free) description homepage;
+ license = licenses.asl20;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.unix;
+ };
+}