commit d5c1891669b8a4ffdbc38ca4963c87fa85da22f8
parent b908374bb73d1253130759bab8241cef351835f5
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Fri, 7 May 2021 12:18:02 +0300
Up
Diffstat:
9 files changed, 44 insertions(+), 93 deletions(-)
diff --git a/nix/sources.json b/nix/sources.json
@@ -37,20 +37,6 @@
"url": "https://github.com/BourgeoisLab/GPXLab/archive/0a2e13756ed1c39f4278b0b3d6cef7f8ac9f6fe7.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
- "gpxsee-maps": {
- "branch": "master",
- "builtin": false,
- "date": "2021-03-02T21:46:10Z",
- "description": "GPXSee maps",
- "homepage": "https://tumic0.github.io/GPXSee-maps",
- "owner": "tumic0",
- "repo": "GPXSee-maps",
- "rev": "cb60f47393f79ce0e279ee08b0697acda2ded7e9",
- "sha256": "0ncyk268l0wvxp897j0nyp217aj2zwda7528ar5105csjg2bfdyc",
- "type": "tarball",
- "url": "https://github.com/tumic0/GPXSee-maps/archive/cb60f47393f79ce0e279ee08b0697acda2ded7e9.tar.gz",
- "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
- },
"klogg": {
"branch": "master",
"builtin": false,
@@ -117,47 +103,5 @@
"type": "tarball",
"url": "https://github.com/odict/odict/archive/639dbab4feac15c4f69049bfb9b7bcfecaf68b47.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
- },
- "openmtbmap": {
- "branch": "master",
- "builtin": false,
- "date": "2020-06-10T11:16:05Z",
- "description": "Linux script to extract and compile garmin *.img map files from openmtbmap.org or openvelomap.org downloads",
- "homepage": "https://github.com/btittelbach/openmtbmap_openvelomap_linux",
- "owner": "btittelbach",
- "repo": "openmtbmap_openvelomap_linux",
- "rev": "de24cd5d4168d8571c544ac42c51883af957a01a",
- "sha256": "1llhdxd9205cj2v0vxynxx9hwliw7pk7w1pac58dmsrwp5h54kr7",
- "type": "tarball",
- "url": "https://github.com/btittelbach/openmtbmap_openvelomap_linux/archive/de24cd5d4168d8571c544ac42c51883af957a01a.tar.gz",
- "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
- },
- "pyephem": {
- "branch": "master",
- "builtin": false,
- "date": "2021-02-20T09:14:48Z",
- "description": "Scientific-grade astronomy routines for Python",
- "homepage": "https://rhodesmill.org/pyephem",
- "owner": "brandon-rhodes",
- "repo": "pyephem",
- "rev": "6aac05e01f2bfc323779b21933721a4a059b1564",
- "sha256": "1p1d6s8jnrnlvk55p5spzjyv5cm8h4xggxzl2piwlirpkai4933a",
- "type": "tarball",
- "url": "https://github.com/brandon-rhodes/pyephem/archive/6aac05e01f2bfc323779b21933721a4a059b1564.tar.gz",
- "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
- },
- "qtpbfimageplugin-styles": {
- "branch": "master",
- "builtin": false,
- "date": "2020-04-10T11:06:10Z",
- "description": "QtPBFImagePlugin styles",
- "homepage": "https://github.com/tumic0/QtPBFImagePlugin-styles",
- "owner": "tumic0",
- "repo": "QtPBFImagePlugin-styles",
- "rev": "577bb119641c80e1736815ed70a0b99c942c63e0",
- "sha256": "1vj1db35prm4npww6vzjkjd12aqvyvkhwg35fg4m4mbfz0d289qx",
- "type": "tarball",
- "url": "https://github.com/tumic0/QtPBFImagePlugin-styles/archive/577bb119641c80e1736815ed70a0b99c942c63e0.tar.gz",
- "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
}
}
diff --git a/pkgs/data/maps/gpxsee-maps/default.nix b/pkgs/data/maps/gpxsee-maps/default.nix
@@ -1,6 +1,6 @@
{ lib
, stdenvNoCC
-, sources
+, fetchFromGitHub
, maptilerApiKey ? ""
, mapboxApiKey ? ""
, thunderforestApiKey ? ""
@@ -22,9 +22,14 @@
stdenvNoCC.mkDerivation {
pname = "gpxsee-maps";
- version = lib.substring 0 10 sources.gpxsee-maps.date;
+ version = "2021-04-03";
- src = sources.gpxsee-maps;
+ src = fetchFromGitHub {
+ owner = "tumic0";
+ repo = "GPXSee-maps";
+ rev = "5adba63fbb5d3919671454d32c802bc1a26c5308";
+ hash = "sha256-pEEpcHl4d6lNHWFlxJot8/swUuE7g6mJSbwhUNbUv5k=";
+ };
postPatch = ''
substitute World/MapTiler.tpl World/MapTiler.xml \
@@ -53,7 +58,8 @@ stdenvNoCC.mkDerivation {
'';
meta = with lib; {
- inherit (sources.gpxsee-maps) description homepage;
+ description = "GPXSee maps";
+ homepage = "https://tumic0.github.io/GPXSee-maps/";
license = licenses.unlicense;
maintainers = [ maintainers.sikmir ];
platforms = platforms.all;
diff --git a/pkgs/data/maps/mtk-suomi/default.nix b/pkgs/data/maps/mtk-suomi/default.nix
@@ -2,11 +2,11 @@
stdenvNoCC.mkDerivation rec {
pname = "mtk-suomi";
- version = "2021-04-16";
+ version = "2021-04-25";
src = fetchurl {
url = "https://kartat-dl.hylly.org/${version}/mtk_suomi.img";
- sha256 = "01kfb4h22z0c3qisgjwwf546i086gw8jfs1c52yc8agkal16fi46";
+ hash = "sha256-ue59ZjJWtmFjGVFrIzBZtF+FowMU8A+IHuZVS9ViDl4=";
};
preferLocalBuild = true;
diff --git a/pkgs/data/maps/qmapshack-onlinemaps/default.nix b/pkgs/data/maps/qmapshack-onlinemaps/default.nix
@@ -1,11 +1,15 @@
-{ lib, fetchzip }:
-
-fetchzip {
- name = "qmapshack-onlinemaps-2020-08-09";
+{ lib, fetchwebarchive, unzip }:
+fetchwebarchive {
+ name = "qmapshack-onlinemaps-2021-01-26";
url = "http://www.mtb-touring.net/wp-content/uploads/Onlinemaps.zip";
- sha256 = "06pwn8l2wr3h0m70pn1ngzs5fvabps1wiqilgdxiw43dhiy94rv9";
- stripRoot = false;
+ timestamp = "20210507005409";
+ hash = "sha256-WD2t7ZiweHMy2Mx1SE2oFWlgWk33s5JBybdNKartNnI=";
+ downloadToTemp = true;
+ recursiveHash = true;
+ postFetch = ''
+ ${unzip}/bin/unzip $downloadedFile -d $out
+ '';
meta = with lib; {
description = "Onlinekarten einbinden";
diff --git a/pkgs/data/themes/goldendict-themes/arc-dark-theme.nix b/pkgs/data/themes/goldendict-themes/arc-dark-theme.nix
@@ -1,7 +1,7 @@
{ lib, fetchgit }:
(fetchgit {
- name = "goldendict-arc-dark-theme-2019-04-06";
+ name = "goldendict-arc-dark-theme-2020-04-06";
url = "https://gist.github.com/ManiaciaChao/ddb14a09a12c95f134003bcd552dced4";
rev = "af58374";
sha256 = "0z3rsi87bf6mlb9syqvsz1jg74i3mxf2cxq43jlfr9zkdmnwgj18";
diff --git a/pkgs/data/themes/qtpbfimageplugin-styles/default.nix b/pkgs/data/themes/qtpbfimageplugin-styles/default.nix
@@ -1,10 +1,15 @@
-{ lib, stdenv, sources }:
+{ lib, stdenv, fetchFromGitHub }:
-stdenv.mkDerivation {
+stdenv.mkDerivation rec {
pname = "qtpbfimageplugin-styles";
- version = lib.substring 0 10 sources.qtpbfimageplugin-styles.date;
+ version = "2020-04-10";
- src = sources.qtpbfimageplugin-styles;
+ src = fetchFromGitHub {
+ owner = "tumic0";
+ repo = pname;
+ rev = "577bb119641c80e1736815ed70a0b99c942c63e0";
+ hash = "sha256-HSckGvhuVVLJc2U8Duf2GysRmpzyb8P5taTmW8ZqQe4=";
+ };
installPhase = ''
install -dm755 $out/share/gpxsee/style
@@ -12,7 +17,8 @@ stdenv.mkDerivation {
'';
meta = with lib; {
- inherit (sources.qtpbfimageplugin-styles) description homepage;
+ description = "QtPBFImagePlugin styles";
+ inherit (src.meta) homepage;
license = licenses.free;
maintainers = [ maintainers.sikmir ];
platforms = platforms.all;
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -103,7 +103,6 @@ lib.makeScope newScope (
lru-dict = callPackage ./development/python-modules/lru-dict { };
mercantile = callPackage ./development/python-modules/mercantile { };
mikatools = callPackage ./development/python-modules/mikatools { };
- pyephem = callPackage ./development/python-modules/pyephem { };
pymbtiles = callPackage ./development/python-modules/pymbtiles { };
python-hfst = callPackage ./development/python-modules/python-hfst { };
s2sphere = callPackage ./development/python-modules/s2sphere { };
diff --git a/pkgs/development/python-modules/pyephem/default.nix b/pkgs/development/python-modules/pyephem/default.nix
@@ -1,14 +0,0 @@
-{ lib, python3Packages, sources }:
-
-python3Packages.buildPythonPackage {
- pname = "pyephem-unstable";
- version = lib.substring 0 10 sources.pyephem.date;
-
- src = sources.pyephem;
-
- meta = with lib; {
- inherit (sources.pyephem) description homepage;
- license = licenses.lgpl3;
- maintainers = [ maintainers.sikmir ];
- };
-}
diff --git a/pkgs/garmin/openmtbmap/default.nix b/pkgs/garmin/openmtbmap/default.nix
@@ -1,10 +1,15 @@
-{ lib, stdenv, gmaptool, mkgmap, p7zip, zsh, sources, substituteAll }:
+{ lib, stdenv, fetchFromGitHub, gmaptool, mkgmap, p7zip, zsh, substituteAll }:
stdenv.mkDerivation {
pname = "openmtbmap";
- version = lib.substring 0 10 sources.openmtbmap.date;
+ version = "2020-06-10";
- src = sources.openmtbmap;
+ src = fetchFromGitHub {
+ owner = "btittelbach";
+ repo = "openmtbmap_openvelomap_linux";
+ rev = "de24cd5d4168d8571c544ac42c51883af957a01a";
+ hash = "sha256-J09SYLk869pQYeoGfuY9PFIOU+/W9w22kKwAkVpvkNI=";
+ };
patches = (substituteAll {
src = ./0001-fix-path.patch;
@@ -18,7 +23,8 @@ stdenv.mkDerivation {
'';
meta = with lib; {
- inherit (sources.openmtbmap) description homepage;
+ description = "Linux script to extract and compile garmin *.img map files from openmtbmap.org or openvelomap.org downloads";
+ inherit (src.meta) homepage;
license = licenses.free;
maintainers = [ maintainers.sikmir ];
platforms = platforms.all;