commit d4a1edd49f43977583a3af1d1c1660ff89e39f83
parent 46a68454ddfb196c48807c8a3ce5687da3401c0b
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Sat, 25 Apr 2020 05:26:45 +0300
Add gpxsee-poi
Diffstat:
2 files changed, 70 insertions(+), 0 deletions(-)
diff --git a/pkgs/data/maps/gpxsee-poi/default.nix b/pkgs/data/maps/gpxsee-poi/default.nix
@@ -0,0 +1,69 @@
+{ lib, fetchurl, gzip, jq }:
+
+{
+ geocachingSu = fetchurl {
+ name = "geocaching_su-2020-04-25";
+ url = "https://nakarte.me/geocachingSu/geocaching_su2.json";
+ sha256 = "sha256-suexI3GL8QWAaxonKQwi0qcPbvUF2GBjiRVnacoP0lk=";
+ downloadToTemp = true;
+ recursiveHash = true;
+ preferLocalBuild = true;
+ postFetch = ''
+ install -dm755 $out/share/gpxsee/POI
+ cat $downloadedFile | \
+ ${gzip}/bin/gzip -d | \
+ ${jq}/bin/jq -r '.[]|[.[3],.[2],.[0]]|@csv' > $out/share/gpxsee/POI/geocaching.su.csv
+ '';
+
+ meta = with lib; {
+ homepage = "https://geocaching.su/";
+ description = "Geocaches";
+ maintainers = with maintainers; [ sikmir ];
+ license = licenses.free;
+ platforms = platforms.all;
+ skip.ci = true;
+ };
+ };
+
+ laavut = fetchurl {
+ name = "laavut-2020-04-24";
+ url = "http://www.laavu.org/lataa.php?paikkakunta=kaikki";
+ sha256 = "sha256-wFWsvLh43/NY3CeP4bo5egTT3jonrltjKLlZPfUlUlI=";
+ downloadToTemp = true;
+ recursiveHash = true;
+ preferLocalBuild = true;
+ postFetch = ''
+ install -Dm644 $downloadedFile $out/share/gpxsee/POI/Laavut-kodat.gpx
+ '';
+
+ meta = with lib; {
+ homepage = "http://www.laavu.org/";
+ description = "Laavut ja kodat kartalla";
+ maintainers = with maintainers; [ sikmir ];
+ license = licenses.free;
+ platforms = platforms.all;
+ skip.ci = true;
+ };
+ };
+
+ autiotuvat = fetchurl {
+ name = "autiotuvat-2020-01-13";
+ url = "http://www.laavu.org/autiotuvat/lataa.php?paikkakunta=kaikki";
+ sha256 = "sha256-HxTZiWMyxL3KanU8EOJzrEV4mFBpJVKorpVafXupZAs=";
+ downloadToTemp = true;
+ recursiveHash = true;
+ preferLocalBuild = true;
+ postFetch = ''
+ install -Dm644 $downloadedFile $out/share/gpxsee/POI/Autiotuvat.gpx
+ '';
+
+ meta = with lib; {
+ homepage = "http://www.laavu.org/autiotuvat/";
+ description = "Autiotuvat kartalla";
+ maintainers = with maintainers; [ sikmir ];
+ license = licenses.free;
+ platforms = platforms.all;
+ skip.ci = true;
+ };
+ };
+}
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -34,6 +34,7 @@ lib.makeScope newScope (
wiktionary = callPackage ./data/dicts/wiktionary {};
gpxsee-maps = callPackage ./data/maps/gpxsee-maps {};
+ gpxsee-poi = callPackage ./data/maps/gpxsee-poi {};
hiblovgpsmap = callPackage ./data/maps/hiblovgpsmap {};
maptourist = callPackage ./data/maps/maptourist {};
mtk-suomi = callPackage ./data/maps/mtk-suomi {};