commit d405906b40684c40ad0616bd6c8ea7e9dfee95f3
parent d31ef21babb1c6410245c0dedd4ea9be81547a35
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Sat, 24 Oct 2020 23:20:57 +0300
Add klogg
Diffstat:
3 files changed, 44 insertions(+), 0 deletions(-)
diff --git a/nix/sources.json b/nix/sources.json
@@ -456,6 +456,20 @@
"url": "https://github.com/sgillies/jsonseq/archive/d9a9c86c6c05abca1ed2bdbff248eb3cd9f214fd.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
+ "klogg": {
+ "branch": "master",
+ "builtin": false,
+ "date": "2020-10-23T10:09:03Z",
+ "description": "A fast, advanced log explorer based on glogg project",
+ "homepage": "https://github.com/variar/klogg",
+ "owner": "variar",
+ "repo": "klogg",
+ "rev": "49f67f908ed5d0a076912cb48673f4ddb6c890d2",
+ "sha256": "0qj4n02jpxgl9d0nz4w6cim035x4blk68lxi3nw00d8xczw39nmf",
+ "type": "tarball",
+ "url": "https://github.com/variar/klogg/archive/49f67f908ed5d0a076912cb48673f4ddb6c890d2.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
"libshell": {
"branch": "master",
"builtin": false,
diff --git a/pkgs/applications/misc/klogg/default.nix b/pkgs/applications/misc/klogg/default.nix
@@ -0,0 +1,27 @@
+{ stdenv, lib, mkDerivation, cmake, ninja, sources }:
+let
+ pname = "klogg";
+ date = lib.substring 0 10 sources.klogg.date;
+ version = "unstable-" + date;
+in
+mkDerivation {
+ inherit pname version;
+ src = sources.klogg;
+
+ nativeBuildInputs = [ cmake ninja ];
+
+ enableParallelBuilding = true;
+
+ postPatch = lib.optionalString stdenv.isLinux ''
+ patchelf --set-interpreter $(cat $NIX_CC/nix-support/dynamic-linker) \
+ --set-rpath "$out/lib:${lib.makeLibraryPath [ stdenv.cc.cc.lib ]}" \
+ 3rdparty/sentry/dump_syms/linux/dump_syms
+ '';
+
+ meta = with lib; {
+ inherit (sources.klogg) description homepage;
+ license = licenses.gpl3Plus;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.unix;
+ };
+}
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -21,6 +21,9 @@ lib.makeScope newScope (
gpxsee-bin = callPackage ./applications/gpxsee/bin.nix { };
i18n-editor = callPackage ./applications/i18n-editor { jre = pkgs.jdk11; };
iterm2-bin = callPackage ./applications/iterm2/bin.nix { };
+ klogg = libsForQt5.callPackage ./applications/misc/klogg {
+ inherit sources;
+ };
librewolf = callPackage ./applications/networking/librewolf { };
macpass-bin = callPackage ./applications/macpass/bin.nix { };
mapsoft = callPackage ./applications/gis/mapsoft { };