commit d258655c4bc056896ff61e0d04db03e49d325f86
parent 594a505f8f003226aea796d9de70b89fdfe6600d
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Fri, 27 Dec 2019 16:30:45 +0300
Add ueberzug
Diffstat:
3 files changed, 34 insertions(+), 0 deletions(-)
diff --git a/default.nix b/default.nix
@@ -75,4 +75,7 @@ in {
else callPackage ./pkgs/stardict-tools {
inherit (sources) stardict-3;
};
+ ueberzug = python3Packages.callPackage ./pkgs/ueberzug {
+ inherit (sources) ueberzug;
+ };
}
diff --git a/nix/sources.json b/nix/sources.json
@@ -202,5 +202,17 @@
"type": "tarball",
"url": "https://github.com/huzheng001/stardict-3/archive/8c5c26996dca52d6bda0aedb5da0381db930a733.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
+ "ueberzug": {
+ "branch": "master",
+ "description": "ueberzug is an alternative for w3mimgdisplay",
+ "homepage": "",
+ "owner": "seebye",
+ "repo": "ueberzug",
+ "rev": "6f488070a8eda856289f19b70604c0f80ffd5bf0",
+ "sha256": "1cliar6vsbc2mlrpigk6j13i20832giprargggb5ivscmfakywi8",
+ "type": "tarball",
+ "url": "https://github.com/seebye/ueberzug/archive/6f488070a8eda856289f19b70604c0f80ffd5bf0.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
}
}
diff --git a/pkgs/ueberzug/default.nix b/pkgs/ueberzug/default.nix
@@ -0,0 +1,19 @@
+{ lib, buildPythonApplication, libX11, libXext, xlib, pillow, docopt, psutil
+, attrs, ueberzug }:
+
+buildPythonApplication rec {
+ pname = "ueberzug";
+ version = lib.substring 0 7 src.rev;
+ src = ueberzug;
+
+ buildInputs = [ libX11 libXext ];
+ propagatedBuildInputs = [ xlib pillow docopt psutil attrs ];
+
+ meta = with lib; {
+ description = ueberzug.description;
+ homepage = "https://github.com/seebye/ueberzug";
+ license = licenses.gpl3;
+ platforms = platforms.unix;
+ maintainers = with maintainers; [ sikmir ];
+ };
+}