commit cfbdba2a91555693499b8d641a35462f7a7cd89d
parent 3f487314df38e58e71aec3e64a5ce1aa4d63c389
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Mon, 11 May 2020 00:44:58 +0300
gt4gd: fix build
Diffstat:
1 file changed, 6 insertions(+), 9 deletions(-)
diff --git a/pkgs/tools/dict/gt4gd/default.nix b/pkgs/tools/dict/gt4gd/default.nix
@@ -1,19 +1,16 @@
-{ lib, buildPythonApplication, requests, sources }:
+{ lib, buildPythonApplication, requests, sources
+, withUI ? true, tkinter }:
buildPythonApplication rec {
pname = "gt4gd";
version = lib.substring 0 7 src.rev;
src = sources.google-translate-for-goldendict;
- propagatedBuildInputs = [ requests ];
+ propagatedBuildInputs = [ requests ] ++ (lib.optional withUI tkinter);
- preConfigure = ''
- touch setup.py
- '';
-
- installPhase = ''
- install -Dm755 googletranslate.py $out/bin/gt4gd
- install -Dm644 google_translate.png $out/share/gt4gd/gt.png
+ postInstall = lib.optionalString withUI ''
+ install -Dm755 googletranslateui.py $out/bin/googletranslateui
+ install -Dm644 google_translate.png -t $out/share/gt4gd
'';
meta = with lib; {