commit cf7766cabfe40b91af1ac43870aaac1c22c45fbd
parent b8b3da302e98d4bdbb94b4f05b1f72e0ee7df420
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Thu, 3 Dec 2020 21:22:09 +0300
Add maperitive
Diffstat:
2 files changed, 34 insertions(+), 0 deletions(-)
diff --git a/pkgs/applications/gis/maperitive/bin.nix b/pkgs/applications/gis/maperitive/bin.nix
@@ -0,0 +1,33 @@
+{ stdenv, fetchurl, unzip, mono, gtk2, makeWrapper }:
+
+stdenv.mkDerivation rec {
+ pname = "maperitive-bin";
+ version = "2.4.3";
+
+ src = fetchurl {
+ url = "http://maperitive.net/download/Maperitive-${version}.zip";
+ sha256 = "0j9lfc7pik6hzayb4zz3df4x5fzhyf74r47qj8s4d3827r32a6ya";
+ };
+
+ nativeBuildInputs = [ unzip makeWrapper ];
+
+ installPhase = ''
+ mkdir -p $out/opt/maperitive
+ cp -r . $out/opt/maperitive
+
+ makeWrapper ${mono}/bin/mono $out/bin/maperitive \
+ --prefix LD_LIBRARY_PATH : ${stdenv.lib.makeLibraryPath [ gtk2 ]} \
+ --run "[ -d \$HOME/.maperitive ] || { cp -r $out/opt/maperitive \$HOME/.maperitive && chmod -R +w \$HOME/.maperitive; }" \
+ --add-flags "--desktop \$HOME/.maperitive/Maperitive.exe"
+ '';
+
+ meta = with stdenv.lib; {
+ description = "Desktop application for drawing maps based on OpenStreetMap and GPS data";
+ homepage = "http://maperitive.net/";
+ changelog = "http://maperitive.net/updates.xml";
+ license = licenses.free;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.linux;
+ skip.ci = true;
+ };
+}
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -28,6 +28,7 @@ lib.makeScope newScope (
klogg-bin = callPackage ./applications/misc/klogg/bin.nix { };
librewolf = callPackage ./applications/networking/librewolf { };
macpass-bin = callPackage ./applications/macpass/bin.nix { };
+ maperitive-bin = callPackage ./applications/gis/maperitive/bin.nix { };
mapsoft = callPackage ./applications/gis/mapsoft { };
mapsoft2 = callPackage ./applications/gis/mapsoft/2.nix { };
nnn-plugins = callPackage ./applications/nnn-plugins { };