commit cc66918ac79a986d892068def4552105cb8a6874
parent 489aa688104f3c8751bc69e2d9f59f7bcdf99565
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Thu, 28 Jan 2021 03:12:40 +0300
Add tile-stitch
Diffstat:
3 files changed, 36 insertions(+), 0 deletions(-)
diff --git a/nix/sources.json b/nix/sources.json
@@ -1091,6 +1091,20 @@
"url": "https://github.com/wladich/thinplatespline/archive/55fecd22c7160577b925e03169e74bd488a41cf3.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
+ "tile-stitch": {
+ "branch": "master",
+ "builtin": false,
+ "date": "2019-07-11T00:06:57Z",
+ "description": "Stitch together and crop map tiles for a specified bounding box",
+ "homepage": "https://github.com/ericfischer/tile-stitch",
+ "owner": "ericfischer",
+ "repo": "tile-stitch",
+ "rev": "f14d113c54bb7dcffee05a7608a806b8557139e5",
+ "sha256": "1xq9alsmkz5wpw3cd3xq55046i7c60k5nhx9mssm61ywsvq3yi0h",
+ "type": "tarball",
+ "url": "https://github.com/ericfischer/tile-stitch/archive/f14d113c54bb7dcffee05a7608a806b8557139e5.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
"tilesets-cli": {
"branch": "master",
"builtin": false,
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -152,6 +152,7 @@ lib.makeScope newScope (
lazyscraper = callPackage ./tools/text/lazyscraper { };
py-staticmaps = callPackage ./tools/geo/py-staticmaps { };
supermercado = callPackage ./tools/geo/supermercado { };
+ tile-stitch = callPackage ./tools/geo/tile-stitch { };
tilesets-cli = callPackage ./tools/geo/tilesets-cli { };
tpkutils = callPackage ./tools/geo/tpkutils { };
diff --git a/pkgs/tools/geo/tile-stitch/default.nix b/pkgs/tools/geo/tile-stitch/default.nix
@@ -0,0 +1,21 @@
+{ stdenv, curl, libjpeg, libpng, libtiff, libgeotiff, pkg-config, sources }:
+
+stdenv.mkDerivation {
+ pname = "tile-stitch";
+ version = stdenv.lib.substring 0 10 sources.tile-stitch.date;
+
+ src = sources.tile-stitch;
+
+ nativeBuildInputs = [ pkg-config ];
+
+ buildInputs = [ curl libjpeg libpng libtiff libgeotiff ];
+
+ installPhase = "install -Dm755 stitch -t $out/bin";
+
+ meta = with stdenv.lib; {
+ inherit (sources.tile-stitch) description homepage;
+ license = licenses.bsd2;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.unix;
+ };
+}