commit ca7079d0e646f84283579d7139431c4ee6cb81df
parent 6f0defb04c4b469bc287656c3d12a6fd9ad1303a
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 5 Feb 2023 14:58:57 +0300
arcgis2geojson: fix build
Diffstat:
1 file changed, 7 insertions(+), 2 deletions(-)
diff --git a/pkgs/geospatial/arcgis2geojson/default.nix b/pkgs/geospatial/arcgis2geojson/default.nix
@@ -1,4 +1,4 @@
-{ lib, python3Packages, fetchFromGitHub, poetry }:
+{ lib, python3Packages, fetchFromGitHub }:
python3Packages.buildPythonApplication rec {
pname = "arcgis2geojson";
@@ -12,7 +12,12 @@ python3Packages.buildPythonApplication rec {
hash = "sha256-6lXfQoazBABryyuch1PJF/7yPq7cOBuvGWCqBUVPdts=";
};
- nativeBuildInputs = [ poetry ];
+ postPatch = ''
+ substituteInPlace pyproject.toml \
+ --replace "poetry.masonry" "poetry.core.masonry"
+ '';
+
+ nativeBuildInputs = with python3Packages; [ poetry-core ];
meta = with lib; {
description = "A Python library for converting ArcGIS JSON to GeoJSON";