commit c560e8bd35bbf90f8786eaa365713971477efcc5
parent 06261a777c13327c5c7aeda23d7791c11a1081e4
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Tue, 4 Oct 2022 12:39:03 +0300
Up
Diffstat:
3 files changed, 13 insertions(+), 6 deletions(-)
diff --git a/flake.lock b/flake.lock
@@ -17,11 +17,11 @@
},
"nixpkgs": {
"locked": {
- "lastModified": 1663202367,
- "narHash": "sha256-62sI03nVTWKMULPnjUC+Ig952PqPDnkCSJ56MLoFvDI=",
+ "lastModified": 1664817920,
+ "narHash": "sha256-lGYXsICzTMOvFOcS4N/hmHxOuqnOeuHUGrETefq9u3c=",
"owner": "NixOS",
"repo": "nixpkgs",
- "rev": "e731e6638c7726241c352c74bc7f860872e4cbd2",
+ "rev": "e166ced03f34f5c22a1a643aac860003d9c409b7",
"type": "github"
},
"original": {
diff --git a/pkgs/misc/paho-mqtt-c/default.nix b/pkgs/misc/paho-mqtt-c/default.nix
@@ -11,15 +11,22 @@ stdenv.mkDerivation rec {
hash = "sha256-TGCWA9tOOx0rCb/XQWqLFbXb9gOyGS8u6o9fvSRS6xI=";
};
- nativeBuildInputs = [ cmake ];
+ nativeBuildInputs = [ cmake makeWrapper ];
buildInputs = [ openssl ];
cmakeFlags = [ "-DPAHO_WITH_SSL=TRUE" ];
+ postFixup = ''
+ # for dlopen
+ wrapProgram $out/bin/MQTTVersion \
+ --prefix LD_LIBRARY_PATH : "$out/lib" \
+ --prefix DYLD_LIBRARY_PATH : "$out/lib"
+ '';
+
meta = with lib; {
description = "Eclipse Paho MQTT C Client Library";
- inherit (src.meta) homepage;
+ homepage = "https://www.eclipse.org/paho/";
license = licenses.epl20;
maintainers = [ maintainers.sikmir ];
platforms = platforms.unix;
diff --git a/pkgs/misc/paho-mqtt-cpp/default.nix b/pkgs/misc/paho-mqtt-cpp/default.nix
@@ -17,7 +17,7 @@ stdenv.mkDerivation rec {
meta = with lib; {
description = "Eclipse Paho MQTT C++ Client Library";
- inherit (src.meta) homepage;
+ homepage = "https://www.eclipse.org/paho/";
license = licenses.epl10;
maintainers = [ maintainers.sikmir ];
platforms = platforms.unix;