commit c516093d09a6d6e5b65d4fb31afd5fcdec813908
parent a0694aecb12258692488c21b641ae9f532e0a7e1
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sat, 1 Feb 2025 23:13:56 +0400
Add opcua
Diffstat:
2 files changed, 35 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -382,6 +382,7 @@ lib.makeScope newScope (
nmtree = callPackage ./misc/nmtree { };
objlab = callPackage ./misc/objlab { };
ocelotgui = libsForQt5.callPackage ./misc/ocelotgui { };
+ opcua = callPackage ./misc/opcua { };
#opcua-stack = callPackage ./misc/opcua-stack {
# openssl = pkgs.openssl_1_1;
#};
diff --git a/pkgs/misc/opcua/default.nix b/pkgs/misc/opcua/default.nix
@@ -0,0 +1,34 @@
+{
+ lib,
+ rustPlatform,
+ fetchFromGitHub,
+ pkg-config,
+ openssl,
+}:
+
+rustPlatform.buildRustPackage rec {
+ pname = "opcua";
+ version = "0.12.0-unstable-2024-10-09";
+
+ src = fetchFromGitHub {
+ owner = "locka99";
+ repo = "opcua";
+ rev = "fcc89d8f8b93b5a0943ec8086706e883900faa3c";
+ hash = "sha256-0rwpAVynm0EfE4Wvq37P9O/om+zjNpi7G8iETCfZX6A=";
+ };
+
+ cargoHash = "sha256-rmhEwDrQGX1ISeT2xXg63JjrEqx1oCD6VIfVUGmFFiU=";
+
+ nativeBuildInputs = [ pkg-config ];
+
+ buildInputs = [ openssl ];
+
+ __darwinAllowLocalNetworking = true;
+
+ meta = {
+ description = "Client and server implementation of the OPC UA specification written in Rust";
+ homepage = "https://github.com/locka99/opcua";
+ license = lib.licenses.mpl20;
+ maintainers = [ lib.maintainers.sikmir ];
+ };
+}