commit c2df723eb1549fc94518749d2db6688df6da8e0e
parent eff718e110f5d2b9ea7d746b2d45d23e912a2f50
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 5 Mar 2023 22:15:57 +0400
Add pinentry-touchid
Diffstat:
2 files changed, 32 insertions(+), 0 deletions(-)
diff --git a/pkgs/darwin/pinentry-touchid/default.nix b/pkgs/darwin/pinentry-touchid/default.nix
@@ -0,0 +1,29 @@
+{ lib, buildGoModule, fetchFromGitHub, LocalAuthentication }:
+
+buildGoModule rec {
+ pname = "pinentry-touchid";
+ version = "0.0.3";
+
+ src = fetchFromGitHub {
+ owner = "jorgelbg";
+ repo = "pinentry-touchid";
+ rev = "v${version}";
+ hash = "sha256-XMcJjVVAp5drLMVTShITl0v6uVazrG1/23dVerrsoj4=";
+ };
+
+ vendorHash = "sha256-PJJoTnA9WXzH9Yv/oZfwyjjcbvJwpXxX81vpzTtXWxU=";
+
+ subPackages = [ "." ];
+
+ buildInputs = [ LocalAuthentication ];
+
+ doCheck = false;
+
+ meta = with lib; {
+ description = "Custom GPG pinentry program for macOS that allows using Touch ID";
+ inherit (src.meta) homepage;
+ license = licenses.asl20;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.darwin;
+ };
+}
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -29,6 +29,9 @@ lib.makeScope newScope (
cudatext-bin = callPackage ./darwin/cudatext/bin.nix { };
macpass-bin = callPackage ./darwin/macpass/bin.nix { };
marta-bin = callPackage ./darwin/marta { };
+ pinentry-touchid = callPackage ./darwin/pinentry-touchid {
+ inherit (darwin.apple_sdk.frameworks) LocalAuthentication;
+ };
qutebrowser-bin = callPackage ./darwin/qutebrowser/bin.nix { };
sloth-bin = callPackage ./darwin/sloth { };