commit c1358851d4681d7cae687e52cd6ec4cc57c59268
parent 12fe3825d0e94aee1a1d7e04ce50660e1a8ec9c5
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Tue, 2 Nov 2021 16:10:11 +0300
Revert "CI: update gh actions"
This reverts commit 12fe3825d0e94aee1a1d7e04ce50660e1a8ec9c5.
Diffstat:
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/.github/workflows/build.yml b/.github/workflows/build.yml
@@ -22,7 +22,7 @@ jobs:
runs-on: ${{ matrix.os }}
steps:
- name: Checkout repository
- uses: actions/checkout@v2.3.5
+ uses: actions/checkout@v2.3.4
- name: Install nix
uses: cachix/install-nix-action@v14
with:
@@ -44,7 +44,7 @@ jobs:
-I nixpkgs=$(nix-instantiate --find-file nixpkgs) \
-I $PWD
- name: Build nix packages
- run: nix shell -I 'nixpkgs=channel:nixos-unstable' nixpkgs.nix-build-uncached -c nix-build-uncached ci.nix -A cacheOutputs
+ run: nix run -I 'nixpkgs=channel:nixos-unstable' nixpkgs.nix-build-uncached -c nix-build-uncached ci.nix -A cacheOutputs
env:
NIXPKGS_ALLOW_INSECURE: 1
- name: Trigger NUR update