commit bddd3fa6ba2fdd51a91f387ee35f0452e8ed2ad5
parent fa143ae0dfae5988589f0a807e11fb0941713d29
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sat, 10 Jun 2023 01:53:50 +0400
Add csv2html
Diffstat:
3 files changed, 45 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -329,6 +329,7 @@ lib.makeScope newScope (
};
capture2text = libsForQt5.callPackage ./misc/capture2text { };
cfiles = callPackage ./misc/cfiles { };
+ csv2html = callPackage ./misc/csv2html { };
csvtools = callPackage ./misc/csvtools { };
dns-filter = callPackage ./misc/dns-filter { };
docker-reg-tool = callPackage ./misc/docker-reg-tool { };
diff --git a/pkgs/misc/csv2html/cargo-lock.patch b/pkgs/misc/csv2html/cargo-lock.patch
@@ -0,0 +1,21 @@
+diff --git i/Cargo.lock w/Cargo.lock
+index 169efd7..2238953 100644
+--- i/Cargo.lock
++++ w/Cargo.lock
+@@ -1,5 +1,7 @@
+ # This file is automatically @generated by Cargo.
+ # It is not intended for manual editing.
++version = 3
++
+ [[package]]
+ name = "ansi_term"
+ version = "0.11.0"
+@@ -83,7 +85,7 @@ dependencies = [
+
+ [[package]]
+ name = "csv2html"
+-version = "3.0.0"
++version = "3.0.1"
+ dependencies = [
+ "clap",
+ "csv",
diff --git a/pkgs/misc/csv2html/default.nix b/pkgs/misc/csv2html/default.nix
@@ -0,0 +1,23 @@
+{ lib, stdenv, rustPlatform, fetchFromGitHub }:
+
+rustPlatform.buildRustPackage rec {
+ pname = "csv2html";
+ version = "3.0.1";
+
+ src = fetchFromGitHub {
+ owner = "dbohdan";
+ repo = "csv2html";
+ rev = "v${version}";
+ hash = "sha256-7pEVMdF7rUXKsDrxGFfqwQDIVykgG/x4kh0En1D9VxU=";
+ };
+
+ cargoPatches = [ ./cargo-lock.patch ];
+ cargoHash = "sha256-2Qhu+7Lb6Pvs1a9qH5WmcakxeQVB2bm4fPGZXwh3cgA=";
+
+ meta = with lib; {
+ description = "Convert CSV files to HTML tables";
+ inherit (src.meta) homepage;
+ license = licenses.bsd3;
+ maintainers = [ maintainers.sikmir ];
+ };
+}