commit bddaee1cb5118725116621496692b603c547a6ae
parent b8fa87373771aff53cdff0fc75d115a00a3a11d6
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Sun, 2 Aug 2020 22:18:29 +0300
Add qgis-bin
Diffstat:
2 files changed, 44 insertions(+), 0 deletions(-)
diff --git a/pkgs/applications/qgis/bin.nix b/pkgs/applications/qgis/bin.nix
@@ -0,0 +1,42 @@
+{ stdenv, fetchurl, undmg, releaseType ? "pr" }:
+
+assert releaseType == "pr" || releaseType == "ltr";
+let
+ pname = "qgis";
+ version = {
+ pr = "3.14.1";
+ ltr = "3.10.8";
+ }.${releaseType};
+in
+stdenv.mkDerivation {
+ inherit pname version;
+
+ src = fetchurl {
+ url = "https://qgis.org/downloads/macos/qgis-macos-${releaseType}.dmg";
+ sha256 = {
+ pr = "09c62yxaj0nc64djjxvk5irm0604phir4bfk1wclimvxqc9dvxwz";
+ ltr = "09c62yxaj0nc64djjxvk5irm0604phir4bfk1wclimvxqc9dvxw2";
+ }.${releaseType};
+ name = "QGIS-macOS-${version}.dmg";
+ };
+
+ preferLocalBuild = true;
+
+ nativeBuildInputs = [ undmg ];
+
+ sourceRoot = if releaseType == "pr" then "QGIS$3.14.app" else "QGIS3.app";
+
+ installPhase = ''
+ mkdir -p $out/Applications/QGIS.app
+ cp -R . $out/Applications/QGIS.app
+ '';
+
+ meta = with stdenv.lib; {
+ description = "A Free and Open Source Geographic Information System";
+ homepage = "https://qgis.org";
+ license = licenses.gpl2Plus;
+ maintainers = [ maintainers.sikmir ];
+ platforms = [ "x86_64-darwin" ];
+ skip.ci = true;
+ };
+}
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -27,6 +27,8 @@ lib.makeScope newScope (
inherit sources;
};
openorienteering-mapper-bin = callPackage ./applications/openorienteering-mapper/bin.nix { };
+ qgis-bin = callPackage ./applications/qgis/bin.nix { };
+ qgis-ltr-bin = qgis.override { releaseType = "ltr"; };
qmapshack-bin = callPackage ./applications/qmapshack/bin.nix { };
qutebrowser-bin = callPackage ./applications/qutebrowser/bin.nix { };
redict = libsForQt5.callPackage ./applications/redict {