commit b95a45acc88798fd954786a0ab45bd0545009e0e
parent e53339402a158a936a573edb9fb95d38996c99fa
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Fri, 26 Feb 2021 16:55:32 +0300
Move anki-bin to nixpkgs
Diffstat:
2 files changed, 0 insertions(+), 35 deletions(-)
diff --git a/pkgs/applications/anki/bin.nix b/pkgs/applications/anki/bin.nix
@@ -1,34 +0,0 @@
-{ lib, stdenv, fetchfromgh, undmg }:
-
-stdenv.mkDerivation rec {
- pname = "anki-bin";
- version = "2.1.37";
-
- src = fetchfromgh {
- owner = "ankitects";
- repo = "anki";
- name = "anki-${version}-mac.dmg";
- sha256 = "1f1ac6bwsw5vy08i5jr9xs14vhvja42ww7yv7gd96l4k7ij789rh";
- inherit version;
- };
-
- preferLocalBuild = true;
-
- nativeBuildInputs = [ undmg ];
-
- sourceRoot = "Anki.app";
-
- installPhase = ''
- mkdir -p $out/Applications/Anki.app
- cp -r . $out/Applications/Anki.app
- '';
-
- meta = with lib; {
- homepage = "https://apps.ankiweb.net/";
- description = "Spaced repetition flashcard program";
- license = licenses.agpl3Plus;
- platforms = [ "x86_64-darwin" ];
- maintainers = [ maintainers.sikmir ];
- skip.ci = true;
- };
-}
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -9,7 +9,6 @@ lib.makeScope newScope (
### APPLICATIONS
amethyst-bin = callPackage ./applications/window-managers/amethyst/bin.nix { };
- anki-bin = callPackage ./applications/anki/bin.nix { };
goldencheetah-bin = callPackage ./applications/goldencheetah/bin.nix { };
gpxlab = libsForQt5.callPackage ./applications/gpxlab {
inherit sources;