commit b7cf18e34524d4a61b2f389ed57d72f995736735
parent 0adf4c0c304a0e6914dd4efc579ab70f92f096d4
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Sun, 19 Jan 2025 22:41:39 +0400
Add tuiview
Diffstat:
2 files changed, 41 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -250,6 +250,7 @@ lib.makeScope newScope (
tilekiln = callPackage ./geospatial/tilekiln { };
tilesets-cli = callPackage ./geospatial/tilesets-cli { };
tpkutils = callPackage ./geospatial/tpkutils { };
+ tuiview = callPackage ./geospatial/tuiview { };
vt2geojson = callPackage ./geospatial/vt2geojson { };
titiler = callPackage ./geospatial/titiler { };
tilecloud = callPackage ./geospatial/tilecloud { };
diff --git a/pkgs/geospatial/tuiview/default.nix b/pkgs/geospatial/tuiview/default.nix
@@ -0,0 +1,40 @@
+{
+ lib,
+ stdenv,
+ fetchFromGitHub,
+ python3Packages,
+ gdal,
+}:
+
+python3Packages.buildPythonApplication rec {
+ pname = "tuiview";
+ version = "1.3.0";
+ pyproject = true;
+
+ src = fetchFromGitHub {
+ owner = "ubarsc";
+ repo = "tuiview";
+ tag = "tuiview-${version}";
+ hash = "sha256-DVVJcimEY3m7VkA5XYsJXwE113xhFy4uy7JeIFywfIA=";
+ };
+
+ build-system = with python3Packages; [
+ gdal
+ numpy
+ setuptools
+ ];
+
+ dependencies = with python3Packages; [
+ gdal
+ numpy
+ pyside6
+ ];
+
+ meta = {
+ description = "Simple Raster Viewer";
+ homepage = "https://tuiview.org";
+ license = lib.licenses.gpl2Plus;
+ maintainers = [ lib.maintainers.sikmir ];
+ mainProgram = "tuiview";
+ };
+}