commit b7682f5f4ef2c851fee15c4e4127242ed2810154
parent da6c46dfa2378cfb36cfde1631911a4475bf839e
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Fri, 9 Feb 2024 22:14:30 +0400
Add chasquid
Diffstat:
2 files changed, 34 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -342,6 +342,7 @@ lib.makeScope newScope (
};
capture2text = libsForQt5.callPackage ./misc/capture2text { };
cfiles = callPackage ./misc/cfiles { };
+ chasquid = callPackage ./misc/chasquid { };
csv2html = callPackage ./misc/csv2html { };
csvtools = callPackage ./misc/csvtools { };
diagon = callPackage ./misc/diagon { };
diff --git a/pkgs/misc/chasquid/default.nix b/pkgs/misc/chasquid/default.nix
@@ -0,0 +1,33 @@
+{ lib, stdenv, fetchFromGitHub, buildGoModule, installShellFiles }:
+
+buildGoModule rec {
+ pname = "chasquid";
+ version = "1.13.0";
+
+ src = fetchFromGitHub {
+ owner = "albertito";
+ repo = "chasquid";
+ rev = "v${version}";
+ hash = "sha256-/BSWsDQBfSaXP/7RcCMRnd+nwQwya7vcUl4oZuc+Unk=";
+ };
+
+ vendorHash = "sha256-rx6b48I4Do84K0ffwlTT3moz46FyqEPR6E6cac1xI9E=";
+
+ subPackages = [ "." "cmd/chasquid-util" "cmd/smtp-check" "cmd/mda-lmtp" ];
+
+ nativeBuildInputs = [ installShellFiles ];
+
+ ldflags = [ "-X main.version=${version}" ];
+
+ postInstall = ''
+ installManPage docs/man/*.{1,5}
+ '';
+
+ meta = with lib; {
+ description = "SMTP (email) server with a focus on simplicity, security, and ease of operation";
+ homepage = "https://blitiri.com.ar/p/chasquid/";
+ license = licenses.asl20;
+ maintainers = [ maintainers.sikmir ];
+ mainProgram = "chasquid";
+ };
+}