commit b133bfe047d079a6fe6320672e3c317a3ca92c00
parent 7d9877519e7976ed1da3695b08b11f28326203eb
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Thu, 25 Aug 2022 17:53:33 +0300
Add xyzservices
Diffstat:
2 files changed, 24 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -91,6 +91,7 @@ lib.makeScope newScope (
portolan = callPackage ./development/python-modules/portolan { };
pymbtiles = callPackage ./development/python-modules/pymbtiles { };
s2sphere = callPackage ./development/python-modules/s2sphere { };
+ xyzservices = callPackage ./development/python-modules/xyzservices { };
### EMBOX
diff --git a/pkgs/development/python-modules/xyzservices/default.nix b/pkgs/development/python-modules/xyzservices/default.nix
@@ -0,0 +1,23 @@
+{ lib, stdenv, python3Packages, fetchFromGitHub }:
+
+python3Packages.buildPythonPackage rec {
+ pname = "xyzservices";
+ version = "2022.6.0";
+ disabled = python3Packages.pythonOlder "3.7";
+
+ src = fetchFromGitHub {
+ owner = "geopandas";
+ repo = "xyzservices";
+ rev = version;
+ hash = "sha256-zfLRJLDTitzzcg5LRqaNcrgnL8ruZcTgugso/5wqS9Q=";
+ };
+
+ checkInputs = with python3Packages; [ pytestCheckHook requests mercantile ];
+
+ meta = with lib; {
+ description = "Source of XYZ tiles providers";
+ homepage = "https://xyzservices.readthedocs.io/";
+ license = licenses.bsd3;
+ maintainers = [ maintainers.sikmir ];
+ };
+}