commit a992f5bb4754d9a52d1a3bf13eb35ce93ac3a5e4
parent 4a5c30794eb3cbeb421dcdf3e6aefbd0f1f16021
Author: Nikolay Korotkiy <sikmir@disroot.org>
Date: Thu, 3 Nov 2022 23:35:16 +0300
Add graphene
Diffstat:
2 files changed, 36 insertions(+), 0 deletions(-)
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -307,6 +307,7 @@ lib.makeScope newScope (
glauth = callPackage ./misc/glauth {
buildGoModule = pkgs.buildGo117Module;
};
+ graphene = callPackage ./misc/graphene { };
gsl-lite = callPackage ./misc/gsl-lite { };
how-to-use-pvs-studio-free = callPackage ./misc/pvs-studio/how-to-use-pvs-studio-free.nix { };
huami-token = callPackage ./misc/huami-token { };
diff --git a/pkgs/misc/graphene/default.nix b/pkgs/misc/graphene/default.nix
@@ -0,0 +1,35 @@
+{ lib, stdenv, fetchFromGitHub, perl, pkg-config, wget
+, db, libmicrohttpd, jansson, tcl
+}:
+
+stdenv.mkDerivation rec {
+ pname = "graphene";
+ version = "2.10";
+
+ src = fetchFromGitHub {
+ owner = "slazav";
+ repo = "graphene";
+ rev = version;
+ hash = "sha256-F2C7Ni+D8hWap2szoTFEPMRcWKXpizFWzqqyaDLbrac=";
+ fetchSubmodules = true;
+ };
+
+ postPatch = ''
+ patchShebangs .
+ '';
+
+ nativeBuildInputs = [ perl pkg-config wget ];
+
+ buildInputs = [ db libmicrohttpd jansson tcl ];
+
+ installFlags = [ "prefix=$(out)" "sysconfdir=$(out)/etc" ];
+
+ meta = with lib; {
+ description = "A simple time series database based on BerkleyDB";
+ inherit (src.meta) homepage;
+ license = licenses.gpl3;
+ maintainers = [ maintainers.sikmir ];
+ platforms = platforms.linux;
+ skip.ci = stdenv.isDarwin;
+ };
+}