commit a9325e632b21446aad8c03602233391fa0cce490
parent f6152fa2121815bf03d31707b6e38b00c6039494
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Thu, 19 Dec 2019 21:03:54 +0300
Add gpxsee
Diffstat:
3 files changed, 39 insertions(+), 0 deletions(-)
diff --git a/default.nix b/default.nix
@@ -16,6 +16,9 @@ in {
gpxpy = python3Packages.callPackage ./pkgs/gpxpy {
inherit (sources) gpxpy;
};
+ gpxsee = libsForQt5.callPackage ./pkgs/gpxsee {
+ inherit (sources) GPXSee;
+ };
gpxsee-maps = callPackage ./pkgs/gpxsee-maps {
inherit (sources) GPXSee-maps;
};
diff --git a/nix/sources.json b/nix/sources.json
@@ -11,6 +11,18 @@
"url": "https://github.com/BourgeoisLab/GPXLab/archive/68721865f5fd6a5b2414da47a00778d5c342a461.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
+ "GPXSee": {
+ "branch": "master",
+ "description": "GPS log file viewer and analyzer with support for GPX, TCX, KML, FIT, IGC, NMEA, SLF, LOC, GeoJSON and OziExplorer files.",
+ "homepage": "https://www.gpxsee.org",
+ "owner": "tumic0",
+ "repo": "GPXSee",
+ "rev": "a986293f20fba8cf3a649c0ed308ac8d568ba9fc",
+ "sha256": "0910yjzpsd1cri7rc5738496zl94kb75yma7z7zm7jx5jxmagnmp",
+ "type": "tarball",
+ "url": "https://github.com/tumic0/GPXSee/archive/a986293f20fba8cf3a649c0ed308ac8d568ba9fc.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
"GPXSee-maps": {
"branch": "master",
"description": "GPXSee maps",
diff --git a/pkgs/gpxsee/default.nix b/pkgs/gpxsee/default.nix
@@ -0,0 +1,24 @@
+{ mkDerivation, lib, qmake, qtbase, qttools, qttranslations, GPXSee }:
+
+mkDerivation rec {
+ pname = "gpxsee";
+ version = lib.substring 0 7 src.rev;
+ src = GPXSee;
+
+ nativeBuildInputs = [ qmake qttools ];
+ buildInputs = [ qtbase qttranslations ];
+
+ preConfigure = ''
+ lrelease lang/*.ts
+ '';
+
+ enableParallelBuilding = true;
+
+ meta = with lib; {
+ homepage = "https://www.gpxsee.org/";
+ description = GPXSee.description;
+ license = licenses.gpl3;
+ maintainers = with maintainers; [ sikmir ];
+ platforms = platforms.linux;
+ };
+}