commit a6df009e82779061b7767552c684a2bcad43347a
parent 0a9e8cae055d920c8c807a9ac89aaa0c3dfa4734
Author: Nikolay Korotkiy <sikmir@gmail.com>
Date: Wed, 29 Apr 2020 03:37:36 +0300
Add nnn-plugins
Diffstat:
3 files changed, 38 insertions(+), 0 deletions(-)
diff --git a/nix/sources.json b/nix/sources.json
@@ -408,6 +408,19 @@
"url": "https://github.com/wladich/nakarte/archive/89c3e0a94a848a72d5c2b199100d565a9af0dbab.tar.gz",
"url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
},
+ "nnn": {
+ "branch": "master",
+ "builtin": false,
+ "description": "n³ The missing terminal file manager for X",
+ "homepage": "https://github.com/jarun/nnn",
+ "owner": "jarun",
+ "repo": "nnn",
+ "rev": "5d7095e3b96409b9b3276013bab04d644da70cf5",
+ "sha256": "1plscky2bab7kfl7f8qa39r13f1m9w28m5yymcgfqifpkhq8mmz4",
+ "type": "tarball",
+ "url": "https://github.com/jarun/nnn/archive/5d7095e3b96409b9b3276013bab04d644da70cf5.tar.gz",
+ "url_template": "https://github.com/<owner>/<repo>/archive/<rev>.tar.gz"
+ },
"openmtbmap_openvelomap_linux": {
"branch": "master",
"builtin": false,
diff --git a/pkgs/applications/nnn-plugins/default.nix b/pkgs/applications/nnn-plugins/default.nix
@@ -0,0 +1,24 @@
+{ stdenv, sources }:
+
+stdenv.mkDerivation rec {
+ pname = "nnn-plugins";
+ version = stdenv.lib.substring 0 7 src.rev;
+ src = sources.nnn;
+
+ phases = [ "installPhase" "fixupPhase" ];
+
+ installPhase = ''
+ cd $src/plugins
+ for f in $(find . -maxdepth 1 \( ! -iname "." ! -iname "*.md" \)); do
+ install -Dm755 "$f" -t $out/share/nnn/plugins
+ done
+ '';
+
+ meta = with stdenv.lib; {
+ description = "Plugins extend the capabilities of nnn";
+ homepage = "https://github.com/jarun/nnn/tree/master/plugins";
+ license = licenses.bsd2;
+ platforms = platforms.all;
+ maintainers = with maintainers; [ sikmir ];
+ };
+}
diff --git a/pkgs/default.nix b/pkgs/default.nix
@@ -17,6 +17,7 @@ lib.makeScope newScope (
macpass = callPackage ./applications/macpass {};
mapsoft = callPackage ./applications/mapsoft {};
mapsoft2 = callPackage ./applications/mapsoft/2.nix {};
+ nnn-plugins = callPackage ./applications/nnn-plugins {};
openorienteering-mapper = libsForQt5.callPackage ./applications/openorienteering-mapper {
inherit sources;
};